Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

A button on a certian site does not respond since the site upgraded to https

  • 3 trả lời
  • 1 gặp vấn đề này
  • 15 lượt xem
  • Trả lời mới nhất được viết bởi Nuno Ferreira

more options

Hello, MAC OSX. Firefox 80.0.1

Site is : https://meteofrance.com There is a button "Ajouter une ville". It is supposed to scroll down an input field. Worked until one week ago, does no longer work. Works on all browsers, safe FIREFOX.

Site manager says one week ago they upgraded to https. This + some configuration of Firefox on my Mac is the cause of the button not working. They say.

I have no idea where to start looking for (checked TLS level though, it is max 4 min 3).

Does someone have an idea.

Thanks very much.

Giải pháp được chọn

Thanks to all who have suggested actions.

I have tried so many things that I am not sure which action actually cured the problem.

I have an impression though that after having cleared cookies and cache for this site, the next time I accessed the site the usual warning window about accepting cookies popped-up. I usually respond to that kind of warning : "Accept all". This time I just dismissed the window, not responding at all. Is this (one of) the reason(s) the faulty button is now working ?

In any case my problem is solved. Thanks again very much

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (3)

more options

My guess is that it's something to do with Mixed content blocking in Firefox. This is when the website is HTTPS, but there's still content that's not HTTPS. Generally, when images are not HTTPS, there's no issue. But when there is a script (which is what makes the button function work), it usually gets blocked.

I'd recommend trying to disable mixed content blocking on the website to see if that makes a difference. See Mixed content blocking in Firefox for more information.

My other guess would be that it's caused by Enhanced Tracking Protection. See Enhanced Tracking Protection in Firefox for desktop for information on configuring the feature or disabling it on broken websites.

Hope this helps.

Hữu ích?

more options

Works for me.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Also make sure that the time on your computer is set correctly.

Hữu ích?

more options

Giải pháp được chọn

Thanks to all who have suggested actions.

I have tried so many things that I am not sure which action actually cured the problem.

I have an impression though that after having cleared cookies and cache for this site, the next time I accessed the site the usual warning window about accepting cookies popped-up. I usually respond to that kind of warning : "Accept all". This time I just dismissed the window, not responding at all. Is this (one of) the reason(s) the faulty button is now working ?

In any case my problem is solved. Thanks again very much

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.