Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Firefox block autoplay not working, preferences are showing "Block Audio and Video"

  • 10 trả lời
  • 7 gặp vấn đề này
  • 1641 lượt xem
  • Trả lời mới nhất được viết bởi Mr.Tom4

more options

Hi there!

I have been having trouble with Firefox continuing to autoplay videos even with preferences set to "Block Audio and Video."

If I go to twitter.com or elsewhere Firefox will show that auto play is disabled, but videos will autoplay with no audio. I would just like to get this feature working as autoplaying videos are incredibly annoying!

Thanks for any help!

Firefox 72.0.1

Giải pháp được chọn

You can look at these prefs on the about:config page to see if these values work for you.

  • media.autoplay.default = 5 [0:allow; 1:blockAudible; 5:blockAll]
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true
  • media.autoplay.enabled.user-gestures-needed = false

For user-gestures-needed you can try false and true to see what works for you.

Đọc câu trả lời này trong ngữ cảnh 👍 5

All Replies (10)

more options

Giải pháp được chọn

You can look at these prefs on the about:config page to see if these values work for you.

  • media.autoplay.default = 5 [0:allow; 1:blockAudible; 5:blockAll]
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true
  • media.autoplay.enabled.user-gestures-needed = false

For user-gestures-needed you can try false and true to see what works for you.

Helpful?

more options

Settings have been changed and are working for all media. Thank you so much!

Được chỉnh sửa bởi GuyManSir657438 vào

Helpful?

more options

This is not working, videos is still starting automatically on Bloomberg and many other sites.

Helpful?

more options

I have had this problem for a long time. Previously, I made the suggested changes inside of about:config. This worked to block the autoplay of videos, but it ultimately prevented the playing of videos when I actually clicked on them because I wanted them to play. I have recently Refreshed Firefox hoping to reset all of my tweaks within about:config, and now I am back to the original problem of block autoplay not working.

Furthermore, why should it be necessary to go into the config settings to fix this problem? Why isn't it working as it should by using the standard settings option under Preferences?

I love Firefox and will continue to use it, but this is very annoying. Thanks for any help!

Helpful?

more options

I'm also having this problem. Out of those 4 about:config flags, this one worked:

media.autoplay.block-event.enabled = true

which makes sense. The first one was already set to 5, the second one has to do with addons (I don't have any malicious addons installed), and the fourth one, I don't even know what user gestures are.

Helpful?

more options

brilliant! thank you cor-el!

Helpful?

more options

"Block Audio and Video" still doesn't seem to work correctly in v77.0.1.

I have it blocking audio and video. I go to Twitter, and it seems to work as it's not auto playing and there's a big blue circle play button.

But when I click anywhere on the screen then scroll one notch in any direction the video starts playing. I can even scroll farther down to hide the video, click the empty side of the page, then scroll up to the video then it starts playing.

And get this, even when I click the scrollbar to go down a few lines, the videos star playing. All videos go into auto play mode. I have all my add-ons disabled too. Is this a known ongoing bug in Firefox trying to be resolved?

I'll try some of the config hacks above, but why is the option there in the first place if it's not working correctly?

EDIT: Ok, I tried the above hacks and the only one I had to change was:

  • media.autoplay.enabled.user-gestures-needed = false

The .default setting was already 5 due to the Settings change. Apparently "user-gestures" are causing Twitter to autoplay everything with one mouse click anywhere. Maybe the "Block Audio and Video" permission option should disable that option along with .default=5. Unless all of this is just my configuration.

Được chỉnh sửa bởi Mr.Tom4 vào

Helpful?

more options

"media.autoplay.enabled.user-gestures-needed = false"

This is the only one that has ever worked, and Firefox has now gotten rid of it. This is so unnecessarily complicated. What's its replacement?

Helpful?

more options

media.autoplay.enabled.user-gestures-needed =true has been replaced by media.autoplay.blocking_policy =1 If this isn't working then try media.autoplay.blocking_policy = 2

See also:

More info:

Helpful?

more options

Yup. Thanks.

media.autoplay.blocking_policy = 2

Did the trick again. It was auto set at 1 for some dumb reason even though gestures-needed was false. So it appears Permissions->Autoplay GUI option is still broke since it doesn't modify blocking_policy also.

Helpful?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.