X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Content blocker in Firefox does not have the option to turn it off. Why is that?

Được đăng

Four or five months ago, I saw the Content Blocking shield icon in my Firefox browser. When I clicked on it, there was no option to disable Content Blocking. Then I realized that I probably had to create a Mozilla account. Did that, and suddenly the option was there to disable content blocking. Today I was at the MSN website - which has been crashing my video driver lately, and I thought that perhaps if I shut off content blocking it would help. Lo and behold there is no more shield icon but there is an information icon which contains content blocking info (it is an i inside a circle). Once again there is no 'disable content blocking for this site' option. What gives? How can I get the shield icon and the disable option back?? I currently use Firefox version 68.0.1 (64 bit)

Update: I have noticed that this problem happens only when I am at the MSN website. Thank you for any advice you can provide.

Four or five months ago, I saw the Content Blocking shield icon in my Firefox browser. When I clicked on it, there was no option to disable Content Blocking. Then I realized that I probably had to create a Mozilla account. Did that, and suddenly the option was there to disable content blocking. Today I was at the MSN website - which has been crashing my video driver lately, and I thought that perhaps if I shut off content blocking it would help. Lo and behold there is no more shield icon but there is an information icon which contains content blocking info (it is an i inside a circle). Once again there is no 'disable content blocking for this site' option. What gives? How can I get the shield icon and the disable option back?? I currently use Firefox version 68.0.1 (64 bit) Update: I have noticed that this problem happens only when I am at the MSN website. Thank you for any advice you can provide.
Đính kèm ảnh chụp màn hình

Được chỉnh sửa bởi lamoureuxp vào

Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

Not using any plugins beyond what Mozilla installs with the Firefox browser

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Thông tin chi tiết

RobertJ
  • Top 10 Contributor
105 giải pháp 1175 câu trả lời
Được đăng

Câu trả lời hữu ích

Hi lamoureuxp, Is MSN added to Manage Exceptions for Content Blocking?

Hi lamoureuxp, Is MSN added to Manage Exceptions for Content Blocking?
Bài viết này có hữu ích với bạn không? 1
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17670 giải pháp 159854 câu trả lời
Được đăng

Câu trả lời hữu ích

What does it say in the panel in the Content Blocking section?

If you do not see the shield then there is no blockable content although there might be third-party tracking cookies.

Can you post a screenshot of this panel?

What does it say in the panel in the Content Blocking section? If you do not see the shield then there is no blockable content although there might be third-party tracking cookies. Can you post a screenshot of this panel?
Bài viết này có hữu ích với bạn không? 1
Trích dẫn

Người tạo câu hỏi

I am not able to get a screen shot. As soon as I try, the content blocking information box disappears but it does indicate that there is blockable content on the site.

I am not able to get a screen shot. As soon as I try, the content blocking information box disappears but it does indicate that there is blockable content on the site.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Hello My_Cheese_Is_slipping - no that website is not indicated in the exceptions. I will add it and see if that helps. Thanks for the idea.

Hello My_Cheese_Is_slipping - no that website is not indicated in the exceptions. I will add it and see if that helps. Thanks for the idea.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Hello My_Cheese_Is_slipping - update: I am not able to add that website. There is no shield indicator when I go to MSN.com. See attached image of my exceptions

Hello My_Cheese_Is_slipping - update: I am not able to add that website. There is no shield indicator when I go to MSN.com. See attached image of my exceptions
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17670 giải pháp 159854 câu trả lời
Được đăng

If there is blockable content on the page then this doesn't mean that your current settings would block it. This is just to indicate that you might be able to block content. This is usually about third-party cookies/trackers that you may have allowed.

To actually block content you may have to use a higher blocking setting in "Options/Preferences -> Privacy & Security". See also the Web Console for messages about what content is blocked by tracking protection.


You can temporarily toggle this pref to true with a double-click on the about:config page to keep the panel open.

  • ui.popup.disable_autohide = true

You need to reset the pref to false once you have taken the screenshot.

If there is blockable content on the page then this doesn't mean that your current settings would block it. This is just to indicate that you might be able to block content. This is usually about third-party cookies/trackers that you may have allowed. To actually block content you may have to use a higher blocking setting in "Options/Preferences -> Privacy & Security". See also the Web Console for messages about what content is blocked by tracking protection. *https://developer.mozilla.org/en-US/Tools/Web_Console ---- You can temporarily toggle this pref to true with a double-click on the <b>about:config</b> page to keep the panel open. *ui.popup.disable_autohide = true You need to reset the pref to false once you have taken the screenshot. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox
Bài viết này có hữu ích với bạn không?
Trích dẫn
RobertJ
  • Top 10 Contributor
105 giải pháp 1175 câu trả lời
Được đăng

The only way to add a site to Exceptions is to 'Turn Off Content Blocking For This Site'. Which is what you are looking for. I had a similar issue a few days ago when I was changing my Content Blocking levels to try to simulate a problem but, the Turn Off came back.

The only way to add a site to Exceptions is to 'Turn Off Content Blocking For This Site'. Which is what you are looking for. I had a similar issue a few days ago when I was changing my Content Blocking levels to try to simulate a problem but, the Turn Off came back.
Bài viết này có hữu ích với bạn không?
Trích dẫn
RobertJ
  • Top 10 Contributor
105 giải pháp 1175 câu trả lời
Được đăng

Another thought. Are you using any blocking add-ons which might be blocking content before Firefox gets a chance to?

Another thought. Are you using any blocking add-ons which might be blocking content before Firefox gets a chance to?
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

My_Cheese_Is_Sippin' - no I am not using any other blocking add-ons.

Also, when I am at the MSN.com site, there is no 'shield' icon

My_Cheese_Is_Sippin' - no I am not using any other blocking add-ons. Also, when I am at the MSN.com site, there is no 'shield' icon
Bài viết này có hữu ích với bạn không?
Trích dẫn
RobertJ
  • Top 10 Contributor
105 giải pháp 1175 câu trả lời
Được đăng

cor-el said

If you do not see the shield then there is no blockable content although there might be third-party tracking cookies.

What Content Blocking do you have set in Options -> Privacy & Security?

''cor-el [[#answer-1242249|said]]'' <blockquote> If you do not see the shield then there is no blockable content although there might be third-party tracking cookies. </blockquote> What Content Blocking do you have set in Options -> Privacy & Security?
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

cor-el - I am currently blocking trackers in all windows, as well as 3rd party trackers. I also have 'do not track' option set to Always. The shield for content blocking appears in other websites...just not MSN.com

cor-el - I am currently blocking trackers in all windows, as well as 3rd party trackers. I also have 'do not track' option set to Always. The shield for content blocking appears in other websites...just not MSN.com
Bài viết này có hữu ích với bạn không?
Trích dẫn
RobertJ
  • Top 10 Contributor
105 giải pháp 1175 câu trả lời
Được đăng

Set Cookies to All 3rd Party Cookies and your shield will come back after you Reload All Tabs.

Set Cookies to All 3rd Party Cookies and your shield will come back after you Reload All Tabs.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

That is already selected - see attached. I am beginning to suspect that the MSN website is preventing Firefox from using the content blocker. As the page was loading, I saw the shield appear then disappear. Could be that MSN found a way to block the content blocker....? Anyway, I am giving up on this issue. It is what it is. I appreciate the help from you and "cor-el". Thank you.

That is already selected - see attached. I am beginning to suspect that the MSN website is preventing Firefox from using the content blocker. As the page was loading, I saw the shield appear then disappear. Could be that MSN found a way to block the content blocker....? Anyway, I am giving up on this issue. It is what it is. I appreciate the help from you and "cor-el". Thank you.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Jeremy Sanders 12 giải pháp 142 câu trả lời
Được đăng

Archived.

Archived.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.