Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Can't prevent "Show Sidebars" button from appearing at startup

more options

Despite the advice on this question on the forum, the sidebar appears whenever I open Firefox, regardless of whether it's set to display bookmarks, history, or synced tabs. And the "Show Sidebars" icon is glued to my toolbar (the one with the URL & search fields). Whenever I go to Customize and drag it out of there to the Customize box, where the unused icons live, it reappears every time I close and reopen Firefox. BUG.

One piece of advice on the Forum from 8/8/18 says to "Right-click a bookmark and choose Properties, then check in the lower left corner for a checkbox to "Load this bookmark in the sidebar" and uncheck that box." I have no such checkbox on the bookmarks I've right-clicked, so I obviously can't uncheck it. Besides, this would require looking at every bookmark - grossly impractical.

The other advice on 8/8/18 also doesn't work. It says to rename or remove xulstore.json in the Firefox profile folder. Doing this makes Firefox open without remembering much of anything. This is going after a fly with a sledgehammer.

This should clearly be in Options. It is a constant annoyance to have to click the X on the sidebar every time I open Firefox.

Được chỉnh sửa bởi Roland Tanglao vào

Giải pháp được chọn

The opened/closed "state" of the sidebar is stored in a file which also stores window dimensions and some toolbar customization info. Sometimes the file becomes corrupted with nonsensical values. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstoreOLD.json. If you see a file named localstore.rdf, rename that one to localstoreOLD.rdf, or delete it.

Start Firefox back up again. Does the sidebar default to the closed position?

That mini-reset will hide the classic menu bar and bookmarks toolbar. You can use one of these methods to show the toolbar list and select the desired bars there:

  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key to activate the menu bar temporarily.
  • in Customize mode > Toolbars button (see: Customize Firefox controls, buttons and toolbars)

To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.


ErgonomicNaturalKeyboard said

One piece of advice on the Forum from 8/8/18 says to "Right-click a bookmark and choose Properties, then check in the lower left corner for a checkbox to "Load this bookmark in the sidebar" and uncheck that box." I have no such checkbox on the bookmarks I've right-clicked, so I obviously can't uncheck it.

Thankfully, this was removed in Firefox 63, so you no longer have to worry about a bookmark loading a page in the sidebar. Now you can limit yourself to worrying about add-ons loading a page in the sidebar.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (20)

more options

ErgonomicNaturalKeyboard said

And the "Show Sidebars" icon is glued to my toolbar

That's how you can either turn the sidebar on or off - please see this article and scroll down to the section :

Toggle the sidebar on and off

That doesn't work for you  ?

more options

Not at all.

Of course I can manually turn the sidebar on or off like this, or in other ways, every time I open Firefox.

My problem is that I can't get it to STAY off or permanently get rid of its icon in my bar with the URL box in it.

Thanks for the suggestion, but it doesn't seem that you read my question all the way through.

more options

ErgonomicNaturalKeyboard said

Thanks for the suggestion, but it doesn't seem that you read my question all the way through.

But I did : You said you don't want to have the click the X on the sidebar - but what is mentioned in the article I gave you a link to is just as much of a hassle (sorry ....).

As you have tried just about everything in the book to no avail, would you take a look at the Chosen Solution in this thread and see if maybe, just maybe, this could be the solution for you  ?

https://support.mozilla.org/en-US/questions/1180730

Your system details show that you have the DuckDuckGo extension installed ......

more options

Thanks. I read the entire Chosen Solution thread you linked to above. I removed the DuckDuckGo extension from Extensions. I removed it from the list of search engines in Options/Search. Nothing changed.

You still haven't mentioned the persistent icon for the Sidebar in the bar with the URL & search boxes, which comes back every time I close and reopen Firefox. No matter how I remove it from that toolbar.

Is there some way to get the Mozilla team to fix this bug and put a proper option in Options for this fairly recent addition that is such a pain?

more options

Giải pháp được chọn

The opened/closed "state" of the sidebar is stored in a file which also stores window dimensions and some toolbar customization info. Sometimes the file becomes corrupted with nonsensical values. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstoreOLD.json. If you see a file named localstore.rdf, rename that one to localstoreOLD.rdf, or delete it.

Start Firefox back up again. Does the sidebar default to the closed position?

That mini-reset will hide the classic menu bar and bookmarks toolbar. You can use one of these methods to show the toolbar list and select the desired bars there:

  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key to activate the menu bar temporarily.
  • in Customize mode > Toolbars button (see: Customize Firefox controls, buttons and toolbars)

To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.


ErgonomicNaturalKeyboard said

One piece of advice on the Forum from 8/8/18 says to "Right-click a bookmark and choose Properties, then check in the lower left corner for a checkbox to "Load this bookmark in the sidebar" and uncheck that box." I have no such checkbox on the bookmarks I've right-clicked, so I obviously can't uncheck it.

Thankfully, this was removed in Firefox 63, so you no longer have to worry about a bookmark loading a page in the sidebar. Now you can limit yourself to worrying about add-ons loading a page in the sidebar.

more options

The toolbar customization is stored as a pref in about:config and prefs.js.

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

ErgonomicNaturalKeyboard said

The other advice on 8/8/18 also doesn't work. It says to rename or remove xulstore.json in the Firefox profile folder.

As you say that renaming or removing xulstore.json doesn't work either, I assume that you've tried ...... (?)

more options

ErgonomicNaturalKeyboard said

You still haven't mentioned the persistent icon for the Sidebar in the bar with the URL & search boxes, which comes back every time I close and reopen Firefox. No matter how I remove it from that toolbar.

In all honesty : I don't have a clue, other than to ask you this (probably rhetorical) question : After you dragged the icon to the customize page, did you then press the "Done" button  ?

Được chỉnh sửa bởi McCoy vào

more options

jscher2000 said

The opened/closed "state" of the sidebar is stored in a file which also stores window dimensions and some toolbar customization info. Sometimes the file becomes corrupted with nonsensical values. You can rename the file and have Firefox rebuild it. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either
  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter
In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either:
  • "3-bar" menu button > Exit
  • (menu bar) File > Exit
Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstoreOLD.json. If you see a file named localstore.rdf, rename that one to localstoreOLD.rdf, or delete it. Start Firefox back up again. Does the sidebar default to the closed position? That mini-reset will hide the classic menu bar and bookmarks toolbar. You can use one of these methods to show the toolbar list and select the desired bars there:
  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key to activate the menu bar temporarily.
  • in Customize mode > Toolbars button (see: Customize Firefox controls, buttons and toolbars)
To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.

ErgonomicNaturalKeyboard said

One piece of advice on the Forum from 8/8/18 says to "Right-click a bookmark and choose Properties, then check in the lower left corner for a checkbox to "Load this bookmark in the sidebar" and uncheck that box." I have no such checkbox on the bookmarks I've right-clicked, so I obviously can't uncheck it.

Thankfully, this was removed in Firefox 63, so you no longer have to worry about a bookmark loading a page in the sidebar. Now you can limit yourself to worrying about add-ons loading a page in the sidebar.

more options

Thanks to jscher2000 for the tip that worked.

Yes, I had tried renaming xulstore.json before, but was put off by Firefox opening without my toolbars, in a weird position on my screen, and with a horizontal line of garbage across the middle of the Firefox window.

When jscher2000 explained what xulstore.json stores, I again renamed it, opened Firefox, the sidebar was gone, and I reopened my toolbars and positioned the window where I want it. It now works fine. Thanks very much.

However, the sidebar icon is still glued to the bar with the URL and search boxes. Nothing gets rid of that. This isn't much of a problem, though, so I don't mind.

Thanks also to McCoy for continuing to try to help. Yes, I did press Done on the Customization screen on multiple tries. The articles you referred me to did have the info about renaming xulstore.json, but didn't explain what jscher2000 did about what else happens when you do that, and what you need to redo after you do that.

Thanks also to cor-el (from Krypton, I assume) for the handy suggestion. It doesn't apply in my case, but it could for some people.

Problem solved.

more options

Hi ErgonomicNaturalKeyboard, sounds like you are most of the way there. The Sidebars button should have "Remove from Toolbar" on the context menu when you right-click it. If that isn't working, hmm, something new to figure out.

Được chỉnh sửa bởi jscher2000 vào

more options

Believe me, I've tried all ways of removing it, including the one you mention. Nothing works. It's stuck there. Thanks anyway.

more options

ErgonomicNaturalKeyboard said

Believe me, I've tried all ways of removing it, including the one you mention. Nothing works. It's stuck there.

Strange. Maybe one of your add-ons is related to the sidebar and Firefox forces the button in relation to that. ???

more options

Maybe, but it would take too long to check them all. I'd rather live with it.

Mozilla should fix these 2 bugs. Any way to get them to do it?

more options

You can file a bug report, yes.

Random file corruption of xulstore.json probably can't be fixed unless a cause can be identified. That needs more data to be a useful bug.

Unremovable toolbar buttons are definitely strange. However, you need to rule out extensions as the cause of the problem. As a quick test, can you remove the button in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

Does it come back when you restart normally?

more options

In Safe Mode, the Sidebar icon still appears in its usual place. I removed it, both by right-clicking and selecting Remove from Toolbar, and by going to Customize and dragging it off the toolbar into the Customize box with the other icons I'm not using, then clicking Done.

Regardless of how I removed it, when I closed and reopened Firefox, either in safe or regular mode, the icon reappeared.

So evidently it has nothing to do with the extensions, etc.

While we're on the subject of bugs in this bar (whatever it is called), changing the order of its icons via Customization often doesn't work. They just go back to where they were before I moved them.

more options

The order and selection of icons/controls on the toolbars is stored in a preference named browser.uiCustomization.state in prefs.js (listed in about:config). It could be that something is jammed in there somehow, or that Firefox is not successfully saving changes to prefs.js, or that other software is reverting changes to prefs.js (Advanced SystemCare is known to do that, for example).

If the preference is somehow corrupted, the "Restore Defaults" button at the bottom of the Customize screen is the safest way to reset it.

For problems with prefs.js not saving, see: How to fix preferences that won't save.

more options

Hi ErgnomicNaturalKeyboard :-)

Yes as jscher2000 suggested, if you haven't already, please try removing all of your add-ons and if that doesn't work please try Firefox safe mode.

Cheers!

...Roland

more options

Note that my reply above was meant to address issues with not being able to remove the "Show Sidebars" button from the Navigation Toolbar.

more options

After all this fuss, having forced Firefox to recreate the xulstore.json file, which got rid of the persistent sidebar, I opened the sidebar and the whole problem just came back.

Again, the only way I could get rid of this sidebar was to force Firefox to recreate the xulstore.json file.

So this means I have a choice:

1. Either I never open the sidebar at all (because if I do, it will always open whenever I open Firefox), or

2. If I want ever to use the sidebar, I'm stuck with it always appearing whenever I open Firefox.

I believe I have ruled out the extensions, etc. via Safe Mode.

I believe I have proven that the sidebar icon sticks to the toolbar, no matter what you do.

These are just bugs.

  1. 1
  2. 2