Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Nightly doesn't open links from other apps on Fedora 27

  • 4 trả lời
  • 2 gặp vấn đề này
  • 129 lượt xem
  • Trả lời mới nhất được viết bởi HeadPlug

more options

I have set Nightly as my default browser on Fedora 27, but whenever I click a link in some app, Nightly will just open a blank window. Regular Firefox works fine, though. I've tried switching to GNOME on Xorg to see if it's a Wayland issue, but the problem persists...

Giải pháp được chọn

Did you check that the %u parameter is present in the Firefox .desktop file to pass the URL to Firefox?

Đọc câu trả lời này trong ngữ cảnh 👍 2

Tất cả các câu trả lời (4)

more options

HeadPlug

Sorry, I am not aware of how links from external apps work on the Linux platform. But Nightly is supported in this support forum, but we don't get many questions about Nightly here. And I don't test the pre-release versions of Firefox any longer; "gave them up for Lent" a few years ago. LOL

Please be patient and wait for a more informative answer about Nightly on Linux. Later in the day is when the Linux "experts" arrive on-board, at least during week days. Hit and miss on the weekend.

On Windows OS's there can be only one browser that is the "default browser" for external apps; set a Firefox Release version as the "default browser" and it won't work for Nightly in the same Operating System.

more options

Hi

I use Nightly (a Mozilla build) on Ubuntu 17.10 and I know the issue that you are talking about - I see the same thing.

Let me look into this further for you and I will see what I can find out.

more options

Giải pháp được chọn

Did you check that the %u parameter is present in the Firefox .desktop file to pass the URL to Firefox?

Được chỉnh sửa bởi cor-el vào

more options

cor-el said

Did you check that the %u parameter is present in the Firefox .desktop file to pass the URL to Firefox?

Added it on the Exec line and it did the trick. Thanks!