X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

My address bar is blocked from view

Được đăng

In Firefox 45.2.0, running on Debian Jessie, the header for any Webpage has a rectangular area below the address bar that mostly covers it up. I have no idea how to address this. Changes in zoom do nothing. The rectangular area is the same color as the header fill and is connected to the rest of the header. I assume this is probably (another) bug in Firefox, which I have been using for many years.

In Firefox 45.2.0, running on Debian Jessie, the header for any Webpage has a rectangular area below the address bar that mostly covers it up. I have no idea how to address this. Changes in zoom do nothing. The rectangular area is the same color as the header fill and is connected to the rest of the header. I assume this is probably (another) bug in Firefox, which I have been using for many years.

Được chỉnh sửa bởi RichardBentley vào

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • This plugin provides integration with Gnome Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • The IcedTea-Web Plugin executes Java applets.
  • Shockwave Flash 11.2 r202NoSquint

Remove it Permanently Mouseless browsing

Ứng dụng

  • Firefox 45.2.0
  • Chuỗi đại diện người dùng: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/45.2.0/Linux/en-US/

Tiện ích mở rộng

  • EPUBReader 1.5.0.8 ({5384767E-00D9-40E9-B72F-9CC39D655D6F})
  • Firefox Hello Beta 1.1.14 (loop@mozilla.org)
  • Mouseless Browsing 0.5.6Build201310302030.1-signed.1-signed ({c0bcf963-624b-47fe-aa78-8cc02434cf32})
  • NoSquint 2.1.9.1-signed.1-signed (nosquint@urandom.ca)
  • Remove It Permanently 1.0.6.10.1-signed.1-signed ({1dbc4a33-ea62-4330-966c-7bdad3455322})

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: nouveau -- Gallium 0.4 on NV98
  • adapterDeviceID: Gallium 0.4 on NV98
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: nouveau
  • driverDate:
  • driverVersion: 3.0 Mesa 10.3.2
  • info: {u'CairoUseXRender': 1, u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureSkiaAccelerated': 0, u'AzureContentBackend': u'cairo'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 3
  • supportsHardwareH264: No;
  • webglRenderer: nouveau -- Gallium 0.4 on NV98
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Thay đổi cài đặt

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Không
Scribe 734 giải pháp 3498 câu trả lời
Được đăng

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem. Thank you!

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem. Thank you!
John99 971 giải pháp 13138 câu trả lời
Được đăng

Hi Richard, Thought I would chime in with a couple of comments. I have Jessie installed myself. If problems continue a screenshot may help.

Also be aware if now, or at a later date, you have problems with the unsupported nosquint, that there is now a no squint plus:

By the way Not too sure why your sytem details in the forum (towards top, left edge) are displaying as a plugin

Shockwave Flash 11.2 r202NoSquint 

My Firefox in Jessie seems ok, so this issue may not be a general Firefox bug

Hi Richard, Thought I would chime in with a couple of comments. I have Jessie installed myself. If problems continue a screenshot may help. * [[How do I create a screenshot of my problem?]] Also be aware if now, or at a later date, you have problems with the unsupported nosquint, that there is now a no squint plus: * https://addons.mozilla.org/firefox/addon/nosquint-plus By the way Not too sure why your sytem details in the forum (towards top, left edge) are displaying as a plugin Shockwave Flash 11.2 r202NoSquint My Firefox in Jessie seems ok, so this issue may not be a general Firefox bug

Người tạo câu hỏi

This strikes me as being a problem with Firefox layout, not anything else. So before I continue with generic approaches (most of which have been tried), I am going to be dragged kicking and screaming into web page development; I downloaded DOM inspector and will modify the dimensions of the elements in the header. I think that is what will work. I find it difficult to believe (I've been wrong before) that a different look in the header has anything to do with add-ons that I have installed, as they all address the text or graphical elements in the area below the header. If this doesn't succeed I will get back to you. Thanks for the response.

This strikes me as being a problem with Firefox layout, not anything else. So before I continue with generic approaches (most of which have been tried), I am going to be dragged kicking and screaming into web page development; I downloaded DOM inspector and will modify the dimensions of the elements in the header. I think that is what will work. I find it difficult to believe (I've been wrong before) that a different look in the header has anything to do with add-ons that I have installed, as they all address the text or graphical elements in the area below the header. If this doesn't succeed I will get back to you. Thanks for the response.
John99 971 giải pháp 13138 câu trả lời
Được đăng

A screenshot may have helped. NoSquint may modify both web page content and the User Interface of Firefox. (nosquint is also no longer supported & now buggy)

Firefox itself has many built in tools, keyboard shortcut

Ctrl+Shift+C 

will bring up the inspector.

You may also be interested in:

A screenshot may have helped. NoSquint may modify both web page content and the User Interface of Firefox. (nosquint is also no longer supported & now buggy) Firefox itself has many built in tools, keyboard shortcut Ctrl+Shift+C will bring up the inspector. * https://developer.mozilla.org/docs/Tools/Keyboard_shortcuts#Page_Inspector ** https://developer.mozilla.org/docs/Tools/Page_Inspector You may also be interested in: * Pre release versions have a DOM inspector https://developer.mozilla.org/docs/Tools/DOM_Property_Viewer * The Bowser Console may be what you need, but is off by default. See https://developer.mozilla.org/docs/Tools/Browser_Console#Modifying_the_browser_UI

Người tạo câu hỏi

The problem is still there with NoSquint disabled. You mentioned it is not supported; I just updated Firefox and when it checked the add-ons for compatibility, it passed NoSquint.

Again, I am looking at DOM inspector to modify the header elements first, before I reach for something else. The problem is not a big priority anyhow. I have a number of bugs to fix that are natural occurences in Debian and to a lesser extent in Firefox. Firefox has never really been stable. I find myself continually having to refresh it. That said, I haven't seriously considered any other options except possibly Opera, because of my philosophical viewpoint about open source.

The problem is still there with NoSquint disabled. You mentioned it is not supported; I just updated Firefox and when it checked the add-ons for compatibility, it passed NoSquint. Again, I am looking at DOM inspector to modify the header elements first, before I reach for something else. The problem is not a big priority anyhow. I have a number of bugs to fix that are natural occurences in Debian and to a lesser extent in Firefox. Firefox has never really been stable. I find myself continually having to refresh it. That said, I haven't seriously considered any other options except possibly Opera, because of my philosophical viewpoint about open source.

Người tạo câu hỏi

And I know Opera doesn't follow GNU or Open Source guidelines; I just happen to like it because it's like a plucky little upstart.

And I know Opera doesn't follow GNU or Open Source guidelines; I just happen to like it because it's like a plucky little upstart.
John99 971 giải pháp 13138 câu trả lời
Được đăng

The problem with nosquint is that its own developer no longer provides support and updates. Currently it is on the Firefox blocklist due to breaking zoom addons.mozilla.org/firefox/blocked/ As I mentioned earlier consider nosquint-plus as an alternative.

Firefox has never really been stable. 
I find myself continually having to refresh it. 

I do not need to constantly Refresh Mozilla Firefox or Iceweasel in Debian. The Refresh removes addons and resets some settings. What it is doing is removing some of your changes. Possibly you need to discover what changes you are making that causes this stability problem.

The problem with nosquint is that its own developer no longer provides support and updates. Currently it is on the Firefox blocklist due to breaking zoom addons.mozilla.org/firefox/blocked/ As I mentioned earlier consider nosquint-plus as an alternative. Firefox has never really been stable. I find myself continually having to refresh it. I do not need to constantly [[Refresh Firefox - reset add-ons and settings|Refresh]] Mozilla Firefox or Iceweasel in Debian. The Refresh removes addons and resets some settings. What it is doing is removing some of your changes. Possibly you need to discover what changes you are making that causes this stability problem.