X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Firefox won't load pages unless mouse is moving or keyboard is pressed

Được đăng

Hello,

I've seen this problem listed several times prior to this post, but none of the solutions have helped me.

I've been using Firefox for ages and the last 3 updates or so have been exhibiting this issue. When I attempt to load a website, Firefox will begin to take me to the page and then hang. The circle in the tab will stop moving and it will sit there until I move the mouse or press a button on the keyboard. As long as the mouse is continuously moving or keyboard buttons are pressed, the page will load fine. The same thing happens with YouTube. The video will start and then freeze unless the mouse/keyboard is moved. Firefox also exhibits this behavior when I try to download a file from a website. The download will start and then hang until I move the mouse or press a button, then it will continue for a few seconds and hang again until I repeat the mouse movement or keyboard button press.

So far, I've tried updating Firefox, Java and Flash; starting Firefox in Safe Mode; uninstalling and reinstalling Firefox: doing a complete uninstall and reinstall of Firefox with profile removal and creation. I've run the following ad and malware detection tools with no infections found: Malwarebytes' Anti-Malware, AdwCleaner, SuperAntispyware, Microsoft Safety Scanner, Windows Defender, Spybot Search & Destroy, Kasperky Free Security Scan and Anti-rootkit utility TDSSKiller.

The only thing that I've tried that "seemed" to work was starting Windows in Safe Mode with networking and running Firefox there. I was able to watch YouTube videos without freezing and websites appeared to load properly. Obviously, I can't run in Safe Mode all the time.

I've attached a screenshot of what it looks like when Firefox hangs on Google News. Notice that the images partly load, but a good number of them are either waiting or not loaded.

I hope someone can help me, since I really like Firefox and I'd hate to switch to Chrome or (shudder) IE.

Thanks in advance for your help!

Hello, I've seen this problem listed several times prior to this post, but none of the solutions have helped me. I've been using Firefox for ages and the last 3 updates or so have been exhibiting this issue. When I attempt to load a website, Firefox will begin to take me to the page and then hang. The circle in the tab will stop moving and it will sit there until I move the mouse or press a button on the keyboard. As long as the mouse is continuously moving or keyboard buttons are pressed, the page will load fine. The same thing happens with YouTube. The video will start and then freeze unless the mouse/keyboard is moved. Firefox also exhibits this behavior when I try to download a file from a website. The download will start and then hang until I move the mouse or press a button, then it will continue for a few seconds and hang again until I repeat the mouse movement or keyboard button press. So far, I've tried updating Firefox, Java and Flash; starting Firefox in Safe Mode; uninstalling and reinstalling Firefox: doing a complete uninstall and reinstall of Firefox with profile removal and creation. I've run the following ad and malware detection tools with no infections found: Malwarebytes' Anti-Malware, AdwCleaner, SuperAntispyware, Microsoft Safety Scanner, Windows Defender, Spybot Search & Destroy, Kasperky Free Security Scan and Anti-rootkit utility TDSSKiller. The only thing that I've tried that "seemed" to work was starting Windows in Safe Mode with networking and running Firefox there. I was able to watch YouTube videos without freezing and websites appeared to load properly. Obviously, I can't run in Safe Mode all the time. I've attached a screenshot of what it looks like when Firefox hangs on Google News. Notice that the images partly load, but a good number of them are either waiting or not loaded. I hope someone can help me, since I really like Firefox and I'd hate to switch to Chrome or (shudder) IE. Thanks in advance for your help!

Giải pháp được chọn

philipp - Ah ha! When I disabled all non-Microsoft services in msconfig and restarted the PC, Firefox behaved like it used to with no freezing! So now it's just a matter of figuring out which service(s) are causing the issue, right?

Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.25.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0

Ứng dụng

  • Firefox 35.0
  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; rv:35.0) Gecko/20100101 Firefox/35.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/35.0/WINNT/en-US/

Tiện ích mở rộng

  • Adblock Plus 2.6.7 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (không hoạt động)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: Intel(R) Q45/Q43 Express Chipset
  • adapterDescription2:
  • adapterDeviceID: 0x2e12
  • adapterDeviceID2:
  • adapterDrivers: igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 3034103c
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 2-11-2011
  • driverDate2:
  • driverVersion: 8.15.10.2302
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) Q45/Q43 Express Chipset Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Thay đổi cài đặt

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Không
finitarry 251 giải pháp 3421 câu trả lời
Được đăng

In safe mode, Firefox disables all extensions and third-party themes, ignores settings in userChrome.css and userContent.css, uses the default toolbar layout, and disables hardware acceleration. So, try checking all of those things to make sure that one of them is not causing the problem.

In safe mode, Firefox disables all extensions and third-party themes, ignores settings in userChrome.css and userContent.css, uses the default toolbar layout, and disables hardware acceleration. So, try checking all of those things to make sure that one of them is not causing the problem.

Người tạo câu hỏi

Hi finitarry, I did try to start Firefox in Safe Mode, but the problem remained.

Hi finitarry, I did try to start Firefox in Safe Mode, but the problem remained.
cor-el
  • Top 10 Contributor
  • Moderator
17578 giải pháp 159013 câu trả lời
Được đăng

The presence of malware on the user has been mentioned as a possible cause.

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

The presence of malware on the user has been mentioned as a possible cause. Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked *https://support.mozilla.org/kb/troubleshoot-firefox-issues-caused-malware
FredMcD
  • Top 10 Contributor
4270 giải pháp 59898 câu trả lời
Được đăng

Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

'''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems?

Người tạo câu hỏi

Hi cor-el, I did run all of the anti-malware and anti-spyware programs you have listed and the only thing that they found were some cookies, which I had them remove.

FredMcD, just to clarify, did you want me to remain in safe mode while I checked the websites or did you want me to change the hardware acceleration setting and then restart Firefox with the add-ons turned back on?

Hi cor-el, I did run all of the anti-malware and anti-spyware programs you have listed and the only thing that they found were some cookies, which I had them remove. FredMcD, just to clarify, did you want me to remain in safe mode while I checked the websites or did you want me to change the hardware acceleration setting and then restart Firefox with the add-ons turned back on?
FredMcD
  • Top 10 Contributor
4270 giải pháp 59898 câu trả lời
Được đăng

While in Safe Mode, visit the web sites. Are there any problems?

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

While in Safe Mode, visit the web sites. Are there any problems? Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

Người tạo câu hỏi

FredMcD, I tried running Firefox in both Safe Mode with hardware acceleration disabled and normal mode with hardware acceleration disabled. I'm still experiencing the pausing in both modes.

FredMcD, I tried running Firefox in both Safe Mode with hardware acceleration disabled and normal mode with hardware acceleration disabled. I'm still experiencing the pausing in both modes.

Được chỉnh sửa bởi Keith172 vào

finitarry 251 giải pháp 3421 câu trả lời
Được đăng

Then check the extensions you have installed. Try disabling some, then see if that helps. If not enable those and disable some more, and keep doing that until you no longer see the problem.

Then check the extensions you have installed. Try disabling some, then see if that helps. If not enable those and disable some more, and keep doing that until you no longer see the problem.

Người tạo câu hỏi

finitarry, this is my work PC so I only have 2 extensions installed. Adblock Plus 2.6.7 and Microsoft .NET Framework Assistant 0.0.0. I disabled Adblock and restarted Firefox, same issue. The .NET Framework Assistant was already disabled.

finitarry, this is my work PC so I only have 2 extensions installed. Adblock Plus 2.6.7 and Microsoft .NET Framework Assistant 0.0.0. I disabled Adblock and restarted Firefox, same issue. The .NET Framework Assistant was already disabled.
FredMcD
  • Top 10 Contributor
4270 giải pháp 59898 câu trả lời
Được đăng

Start your Computer in safe mode. Then start Firefox. Try Safe web sites.

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Start your '''Computer''' in safe mode. Then start Firefox. Try '''Safe''' web sites. '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

Câu trả lời hữu ích

FredMcD, I believe that worked last time, but I'm getting ready to head home for the day. I'll try it again first thing and report back then with my findings. Have a great night!

FredMcD, I ''believe'' that worked last time, but I'm getting ready to head home for the day. I'll try it again first thing and report back then with my findings. Have a great night!
FredMcD
  • Top 10 Contributor
4270 giải pháp 59898 câu trả lời
Được đăng

ZZZZZZ zzzzzzzz ZZZZZZZZ zzzzzzzzz

ZZZZZZ zzzzzzzz ZZZZZZZZ zzzzzzzzz

Câu trả lời hữu ích

Good morning FredMcD, sorry for the delay but I was out of the office yesterday.

I started Windows 7 in safe mode with networking and tried Firefox there. Firefox seemed to run normally that way, with no freezing on website loads or YouTube videos.

Good morning FredMcD, sorry for the delay but I was out of the office yesterday. I started Windows 7 in safe mode with networking and tried Firefox there. Firefox seemed to run normally that way, with no freezing on website loads or YouTube videos.
FredMcD
  • Top 10 Contributor
4270 giải pháp 59898 câu trả lời
Được đăng

Okay, it sounds like something on the computer is causing the issue.

Check the programs that are on your computer

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.

Go thru the list. If you find something that you don't know what it is, use a web search.

Troubleshoot Firefox Issues Caused By Malware {web link}

Okay, it sounds like something on the computer is causing the issue. Check the programs that are on your computer '''Windows:''' Start > Control Panel > Uninstall Programs. '''Mac:''' Open the "Applications" folder. '''Linux:''' Check your user manual. Go thru the list. If you find something that you don't know what it is, use a web search. '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware Troubleshoot Firefox Issues Caused By Malware]''' {web link}

Người tạo câu hỏi

FredMcD, I'm with you there. I went through the Programs list and uninstalled some items installed by my predecessor that I don't use. Everything else looks ok. Unfortunately, still no help with the freezing issue though.

FredMcD, I'm with you there. I went through the Programs list and uninstalled some items installed by my predecessor that I don't use. Everything else ''looks'' ok. Unfortunately, still no help with the freezing issue though.
FredMcD
  • Top 10 Contributor
4270 giải pháp 59898 câu trả lời
Được đăng

Did you look at the Troubleshoot link above?

Did you look at the '''Troubleshoot''' link above?

Người tạo câu hỏi

FredMcD, yes I did. I did the following:

  • Started Windows 7 in Safe Mode and re-ran all of the anti-malware and anti-spyware programs I tried before. They only found some cookies, which I removed, no effect on Firefox.
  • Downloaded and installed the NoScript add-on for Firefox, no effect on Firefox.
  • I removed FireFox from the Windows Firewall exception list and re-added it, no effect on FireFox.
  • I changed the Proxy setting from Use System Proxy Settings to No Proxy, no effect on FireFox.
  • I turned off IVP6, no effect on FireFox.
  • I turned off DNS Prefetching, no effect on FireFox.
  • I cleared my cache, no effect on FireFox.

Earlier today, before I did all of the above, I did notice that Firefox would exhibit the freezing behavior on Google News, for example, then after about 20 seconds or so, the page would load the rest of the way. Since I did everything on the above list, that seems to have stopped and I have to move the mouse again or press a button on the keyboard to get the page to load.

As an aside, I 'can' use IE without any issues, I just don't like to.

FredMcD, yes I did. I did the following: * Started Windows 7 in Safe Mode and re-ran all of the anti-malware and anti-spyware programs I tried before. They only found some cookies, which I removed, no effect on Firefox. * Downloaded and installed the NoScript add-on for Firefox, no effect on Firefox. * I removed FireFox from the Windows Firewall exception list and re-added it, no effect on FireFox. * I changed the Proxy setting from Use System Proxy Settings to No Proxy, no effect on FireFox. * I turned off IVP6, no effect on FireFox. * I turned off DNS Prefetching, no effect on FireFox. * I cleared my cache, no effect on FireFox. Earlier today, before I did all of the above, I did notice that Firefox would exhibit the freezing behavior on Google News, for example, then after about 20 seconds or so, the page would load the rest of the way. Since I did everything on the above list, that seems to have stopped and I have to move the mouse again or press a button on the keyboard to get the page to load. As an aside, I 'can' use IE without any issues, I just don't like to.
FredMcD
  • Top 10 Contributor
4270 giải pháp 59898 câu trả lời
Được đăng

Okay, time to get dirty. Here are two things I want you to do. Please follow the instructions. First, we will try a new profile. Once the profile is set up, use it. DO NOT change any settings or anything else. If you still have problems, go to the nest post


https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles Windows: 32-bit C:\Program Files\Mozilla Firefox\firefox.exe -p 64-bit C:\Program Files (x86)\Mozilla Firefox\firefox.exe -p Mac: Navigate to /Applications/Utilities. Open the Terminal application. In the Terminal application, enter the following: /Applications/Firefox.app/Contents/MacOS/firefox-bin -p Linux: In Terminal run: firefox –P For users who have one or more builds from mozilla.org this will not work. It would be best to have the full path so if you had placed the untared contents in a folder in /home it would be /home/<username>/foldername/firefox/firefox –P An easy way would be not to do it in a terminal but in say a launcher since you have to point it to the firefox script in Firefox folder you can then add –P on end. You can also have the exact "profilename" after the -P so Firefox will start with that Profile.

Okay, time to get dirty. Here are two things I want you to do. Please follow the instructions. First, we will try a new profile. Once the profile is set up, use it. DO NOT change any settings or anything else. If you still have problems, go to the nest post --------------------------- '''https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles''' '''Windows: 32-bit''' C:\Program Files\Mozilla Firefox\firefox.exe -p '''64-bit''' C:\Program Files (x86)\Mozilla Firefox\firefox.exe -p '''Mac:''' Navigate to '''/Applications/Utilities.''' Open the Terminal application. In the Terminal application, enter the following: /Applications/Firefox.app/Contents/MacOS/firefox-bin -p '''Linux:''' In '''Terminal''' run: firefox –P For users who have one or more builds from mozilla.org this will not work. It would be best to have the full path so if you had placed the untared contents in a folder in /home it would be /home/<username>/foldername/firefox/firefox –P An easy way would be not to do it in a terminal but in say a launcher since you have to point it to the firefox script in Firefox folder you can then add –P on end. You can also have the exact "profilename" after the -P so Firefox will start with that Profile.
FredMcD
  • Top 10 Contributor
4270 giải pháp 59898 câu trả lời
Được đăng

Download Firefox Full Installer For All languages And Systems {web link} Save the file. Then;

Using your file browser, open the Programs folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder. Linux: Check your user manual.

Look for, and rename any Mozilla and Firefox folders by adding .old to them.

Now run the full installer. If all goes well, remove the OLD folders when you are done.

'''[http://www.mozilla.org/en-US/firefox/all/ Download Firefox Full Installer For All languages And Systems]''' {web link} Save the file. Then; Using your file browser, open the '''Programs''' folder on your computer. '''Windows:''' C:\Program Files C:\Program Files (x86) '''Mac:''' Open the "Applications" folder. '''Linux:''' Check your user manual. Look for, and rename any Mozilla and Firefox folders by adding '''.old''' to them. Now run the full installer. If all goes well, remove the OLD folders when you are done.

Người tạo câu hỏi

FredMcD, I tried both of your suggestions, but unfortunately neither one worked for me.

In case it's of any help, when I say that FireFox hangs, I mean everything about it hangs. If I can get a webpage to load, while I'm reading something on the page, Flash ads will stop animating unless I move the mouse.

FredMcD, I tried both of your suggestions, but unfortunately neither one worked for me. In case it's of any help, when I say that FireFox hangs, I mean everything about it hangs. If I can get a webpage to load, while I'm reading something on the page, Flash ads will stop animating unless I move the mouse.