Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox unstable since 62.0.3

  • 5 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by Ian


I'm a longtime Firefox user and 62.0.3 works flawlessly on my Windows 10 PC. However, every version since then - and I've tried them all, right up to 68.0 - has been unstable. The browser hangs and/or crashes and every time reverting to 62.0.3 instantly fixes the problem. This is now quite an old version, though, and I'm concerned that by using it I'm exposing myself to security issues. Any ideas?

All Replies (5)

hello, could you provide your latest few submitted crash reports? please enter about:crashes into the location bar, copy the latest few report ids from there starting with bp- & paste them here into a forum reply. this will give us a better understanding what may be triggering those crashes.

Hi Philipp,

Is this what you're after?

bp-ce0c3cf0-be9b-4216-87e6-d57990190709 09/07/2019 21:53 bp-8ce635f6-550c-4194-8e02-5c53e0190701 01/07/2019 13:41 bp-19d3ff49-8bc5-4712-9099-2b80f0190521 21/05/2019 22:30 bp-1ea8007f-a68d-41e5-bcbc-136fc0190428 28/04/2019 20:59 bp-4f1ce230-fde4-46e7-8b92-7ecd70190313 13/03/2019 15:29 bp-7ed635d1-8f43-480f-ae8c-12d010190213 13/02/2019 09:09

As you can see I've tried lots of different versions but always end up reverting to the only one that works!

yes thanks. this kind of crash is very rare in general, so there is no boilerplate solution here. are you using any unusual setup in regards to certificates and authentication (like using smartcards, storing personal certs to authenticate to some servers, etc...)?

in any case you might want to try to refresh firefox and see if this can address the issue...

Pretty much every aspect of the installation is absolutely standard. I've tried refreshing, but it doesn't help. The only thing that does is going back to 62.0.3, which doesn't exhibit the problem. There must be a clue there...

And now we're on to 69.0, and it still crashes pretty much instantly. Please find a way of fixing this!