Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how do I add java for skype in firefox version 55

  • 5 பதிலளிப்புகள்
  • 13 இந்த பிரச்னைகள் உள்ளது
  • 4 views
  • Last reply by Paulk645

When I start Skype on my desktop (win7 pro 64bit) I get the message "Your browser is currently set to block JavaScript. You need to allow JavaScript to use this service." It started after the update to version 55 of firefox. How do I enable java for skype as it does not show up as an item in firefox, I am using a standalone version of skype that should not go thru firefox? Thank you for any help

When I start Skype on my desktop (win7 pro 64bit) I get the message "Your browser is currently set to block JavaScript. You need to allow JavaScript to use this service." It started after the update to version 55 of firefox. How do I enable java for skype as it does not show up as an item in firefox, I am using a standalone version of skype that should not go thru firefox? Thank you for any help

All Replies (5)

There are other things that need attention.

The System Details list next to the question shows an outdated Shockwave Flash 18.0 r0 plugin. Make sure all plugins are up-to-date.

You can download the latest Flash player versions for Firefox on this page:

That is all well and good but you answered a question I did not ask. I do not care if all "javas" are not alike, how do I get skype to work on firefox? Updating shockwave won't do it. Neither will educating me on java types. Does anyone have any information on how to get skype working on firefox 55? Thank you

You can check that JavaScript is enabled and isn't blocked.

  • javascript.enabled should be true on the about:config page

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (e.g. Adblock Plus, NoScript, Ghostery, uBlock Origin) always make sure such extensions do not block (wanted) content.

  • make sure your extensions and filters are updated to the latest version

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

I have already tried this - it doesn't solve the problem and created some new ones. I don't recommend anyone to try this solution but that is just my mileage. The only option I see is to uninstall firefox and use another browser (obviously not a microsoft one even tho that is what the owners of skype would like).