Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Multi-Account Containers | Container Name in URL Bar

more options

Firefox 126.0.1 displays a very long name of a container completely in the URL bar.

Firefox 127.0 truncates container names

AWS long account and role names make keeping the long name very convenient (works with the 'AWS SSO Containers' Add-On

Firefox 126.0.1 displays a very long name of a container completely in the URL bar. Firefox 127.0 truncates container names AWS long account and role names make keeping the long name very convenient (works with the 'AWS SSO Containers' Add-On
Attached screenshots

Chosen solution

Thank you for the Github link. It sounds as though this was intentional to ensure that the URL wasn't obscured.

The restriction is in a built-in style sheet, any characters beyond 8em in width are trimmed:

https://searchfox.org/mozilla-release/source/browser/components/contextualidentity/content/usercontext.css#111

If this is a big problem, you could consider delving into the unsupported realm of userChrome.css rules to override built-in rules. In this case, you could use:

#userContext-label {
    max-width: unset !important;
}

The effect is visible in the attached screenshot (which obviously shows a lot of other modifications). If you are new to userChrome.css and want to learn more, I have a site here:

https://www.userchrome.org/

Note: The How To videos are missing the last step about the about:config change.

Read this answer in context 👍 3

All Replies (5)

more options

Itai said

Firefox 126.0.1 displays a very long name of a container completely in the URL bar. Firefox 127.0 truncates container names AWS long account and role names make keeping the long name very convenient (works with the 'AWS SSO Containers' Add-On

More information here https://github.com/mozilla/multi-account-containers/issues/2641

Helpful?

more options

Suluhisho teule

Thank you for the Github link. It sounds as though this was intentional to ensure that the URL wasn't obscured.

The restriction is in a built-in style sheet, any characters beyond 8em in width are trimmed:

https://searchfox.org/mozilla-release/source/browser/components/contextualidentity/content/usercontext.css#111

If this is a big problem, you could consider delving into the unsupported realm of userChrome.css rules to override built-in rules. In this case, you could use:

#userContext-label {
    max-width: unset !important;
}

The effect is visible in the attached screenshot (which obviously shows a lot of other modifications). If you are new to userChrome.css and want to learn more, I have a site here:

https://www.userchrome.org/

Note: The How To videos are missing the last step about the about:config change.

Helpful?

more options

This works great, thank you !

Helpful?

more options

Where precisely in firefox do I find the stylesheet to override it? thank you!

Helpful?

more options

ionut_mntn said

Where precisely in firefox do I find the stylesheet to override it? thank you!

You don't need to change the built-in style sheets to override them. Instead, you create your own file named userChrome.css to override the built-in style sheets.

Helpful?

Uliza swali

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.