Kërkoni te Asistenca

Shmangni karremëzime gjoja asistence. S’do t’ju kërkojmë kurrë të bëni një thirrje apo të dërgoni tekst te një numër telefoni, apo të na jepni të dhëna personale. Ju lutemi, raportoni veprimtari të dyshimtë duke përdorur mundësinë “Raportoni Abuzim”.

Learn More

Websites tell me I need to enable Javascript despite the fact that it is enabled

  • 7 përgjigje
  • 0 e kanë hasur këtë problem
  • 19 parje
  • Përgjigjja më e re nga Larry951

more options

Today a website told me I needed to enable JavaScript in order to continue, despite the fact that it is enabled. At first, when I received this message, I turned off the "NoScript" extension and tried again, but the website still gave me that same message. So then I went to the about:config page. and it showed that JavaScript is enabled because it showed a value of "true". This sort of thing has happened more than once in the past. I'm forced to go to another browser such Microsoft Edge or Chrome, where I do not encounter this problem. Why is this happening in Firefox, and what can I do about it? My operating system is Windows 10 Professional, and if you need any other details, please let me know. I will appreciate your assistance.

Today a website told me I needed to enable JavaScript in order to continue, despite the fact that it is enabled. At first, when I received this message, I turned off the "NoScript" extension and tried again, but the website still gave me that same message. So then I went to the about:config page. and it showed that JavaScript is enabled because it showed a value of "true". This sort of thing has happened more than once in the past. I'm forced to go to another browser such Microsoft Edge or Chrome, where I do not encounter this problem. Why is this happening in Firefox, and what can I do about it? My operating system is Windows 10 Professional, and if you need any other details, please let me know. I will appreciate your assistance.

Zgjidhje e zgjedhur

Make sure you disable extensions from the addons manager, disabling them from the toolbar will still allow them to run.

You may need to clear site cookies in case the site remembers you had javascript disabled.

Also try disabling Tracking Protection for the site.

Lexojeni këtë përgjigje brenda kontekstit 👍 1

Krejt Përgjigjet (7)

more options

NoScript definitely requires a lot of training and management. Even if you trust the current site listed in the address bar, scripts from other servers that are used by the site may still be blocked. I sometimes need to review/adjust multiple times.

The same message also can result from other kinds of blockers, such as ad blockers. It's the price we pay for taking more control of what loads.

E dobishme?

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin), always make sure such extensions do not block content.

You can check for issues with Enhanced Tracking Protection. Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages like blocked content.

E dobishme?

more options

1. jscher2000: Sorry, but I don't think you solved the problem. I don't think NoScript was the source of the problem because as I mentioned in my question, I disabled NoScript but the problem persisted. What I mean by that is I turned off NoScript completely. Also you mentioned other blockers such as ad blockers, but I don't use any of those. Also, your posting doesn't give me any instructions on what to try out, and so I don't know what to do in order to implement whatever it is that you want me to try. 2. cor-el: Thank you for your response, but I didn't have any extensions enabled except for NoScript, which (as I noted above) I disabled, but I still experienced the problem after disabling NoScript.

E dobishme?

more options

Zgjidhja e Zgjedhur

Make sure you disable extensions from the addons manager, disabling them from the toolbar will still allow them to run.

You may need to clear site cookies in case the site remembers you had javascript disabled.

Also try disabling Tracking Protection for the site.

E dobishme?

more options

1. zeroknight: Thank you for your response. I think the problem might have been that I didn't close out of Firefox and then re-open Firefox after I disabled NoScript. The reason I didn't do that is because I wanted to leave some tabs open. Is there a way of disabling NoScript without closing all the tabs? I tried setting it so that all of the listed items were set to "trusted" or "temporarily trusted" but that didn't work. 2. jscher2000 and cor-el: Thanks also to jscher2000 and cor-el. Your responses might have worked for me if I had closed out of Firefox and then re-opened Firefox, and so I apologize for not having done that extra step.

E dobishme?

more options

You can find a Restart button on the about:profiles page that you can use.

E dobishme?

more options

cor-el: Thank you for your reply. I have a couple of related questions:

      1.  Is there a way of setting my settings in Firefox so that when I close Firefox by clicking "X" in the upper-right corner it will automatically do a restart and restore all tabs that had been open?
      2.  In my posting of 2/24/24,  I had mentioned that I tried setting NoScript so that all of the listed items were set to "trusted" or "temporarily trusted" but that didn't work.  Does that happen sometimes with NoScript?  If so,  what are the circumstances?  I suppose it's possible I may have been using an incorrect procedure,  but I don't know what it may have been.  I don't think it was due to an outdated version of NoScript because my Add-Ons manager shows that it is set to update add-ons automatically.

E dobishme?

Bëni një pyetje

Duhet të bëni hyrjen te llogaria juaj që t’i përgjigjeni postimeve. Ju lutemi, filloni me një pyetje të re, nëse nuk keni ende një llogari.