Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Vunerable Adobe Flash Player

  • 4 replies
  • 1 has this problem
  • 1 view
  • Last reply by James

more options

Firefox blocks adobe flash player as vulnerable, saying that it is outdated. I have version 11.2.202.481 on Debian 8 Jessie. However, when I get to the plugin check page (https://www.mozilla.org/en-US/plugincheck/), it then says that my plugin is in fact up to date. The latest version available on the adobe website is 11.2.202.491, but my version is only a week old.

It seems a bit cumbersome to have to manually update flash player every week, especially as the player should be up to date. It is also very irritating to have the content blocked on websites.

All Replies (4)

more options

The .481 version is affected by a critical vulnerability as to why it is blocked along with the previous versions on Windows and Mac OSX.

https://helpx.adobe.com/security/products/flash-player/apsa15-04.html https://www.adobe.com/software/flash/about/ https://www.adobe.com/products/flashplayer/distribution3.html

https://addons.mozilla.org/en-US/firefox/blocked/

Just about every Flash player version was added to blocklist since December due to serious security concerns. Yet Mozilla did not add any version before December since Feb 2013 as they were not of security concerns enough to block.

more options

Are there any alternatives?

more options

If you search for linux flash alternatives you can find some discussion. I haven't tried any of them myself.

more options

P Gajjar said

Are there any alternatives?

Besides using the current not vulnerable (yet) 11.2.202.491

Depending on OS used and site there is GNU Gnash, Unity Web Player, Lightspark and Shumway

They do not work for all sites as some are only partially if works.