Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

all notifications are disabled in Firefox/MacOS after recent update

  • 2 ответа
  • 1 имеет эту проблему
  • 225 просмотров
  • Последний ответ от ptsa4soldiers

more options

Hi all. I've been using Firefox for years on my Mac. It's my browser of choice.

A couple of days ago, my Mac installed an OS update (v13.5.2). After the reboot, I opened Firefox and discovered that it, too, had installed an update (v117.0). But when I got into Gmail and tried to turn on desktop notifications, it said this:

Note: Notifications have been disabled in this browser.

And it's right--no other sites are sending me their usual notifications, either.

My problem is, I can't figure out why notifications are disabled in Firefox suddenly. I didn't disable them. I've tried clicking the lock on gmail's site and setting its permissions to allow notifications, but they aren't coming. I've checked my Mac's preferences, and Firefox has notifications enabled there, as usual. Gmail works fine on Chrome--notifications are working. I've tried reinstalling Firefox--no change. I've tried running Firefox in troubleshooting mode--no joy. Other sites aren't even asking for permission to send notifications. Like Gmail, they appear to believe notifications are disabled in the browser.

I've searched the web for solutions, but I can't find one that tells me where the enable/disable switch is. Can some kind soul please help me out here?

Thank you SO MUCH in advance!!

Hi all. I've been using Firefox for years on my Mac. It's my browser of choice. A couple of days ago, my Mac installed an OS update (v13.5.2). After the reboot, I opened Firefox and discovered that it, too, had installed an update (v117.0). But when I got into Gmail and tried to turn on desktop notifications, it said this: Note: Notifications have been disabled in this browser. And it's right--no other sites are sending me their usual notifications, either. My problem is, I can't figure out why notifications are disabled in Firefox suddenly. I didn't disable them. I've tried clicking the lock on gmail's site and setting its permissions to allow notifications, but they aren't coming. I've checked my Mac's preferences, and Firefox has notifications enabled there, as usual. Gmail works fine on Chrome--notifications are working. I've tried reinstalling Firefox--no change. I've tried running Firefox in troubleshooting mode--no joy. Other sites aren't even asking for permission to send notifications. Like Gmail, they appear to believe notifications are disabled in the browser. I've searched the web for solutions, but I can't find one that tells me where the enable/disable switch is. Can some kind soul please help me out here? Thank you SO MUCH in advance!!

Выбранное решение

Make sure you have not enabled private browsing mode aka "Never remember history" as this will disable notifications. Instead "Use custom settings for history" and untick "Remember browsing and download history".

Does it still happen in Troubleshoot Mode?

Прочитайте этот ответ в контексте 👍 2

Все ответы (2)

more options

Выбранное решение

Make sure you have not enabled private browsing mode aka "Never remember history" as this will disable notifications. Instead "Use custom settings for history" and untick "Remember browsing and download history".

Does it still happen in Troubleshoot Mode?

more options

Hi @zeroknight. Yes, that was the problem. I don't know why it was suddenly in private browsing mode--I hadn't changed a thing--but it was. THANK YOU for solving it for me--it was driving me nuts. You're a rock star!