Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Caută ajutor

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Loading home page

  • 10 răspunsuri
  • 0 au această problemă
  • Ultimul răspuns de sciencemagic

more options

It takes a lot longer than it should to load my home page, MSN. This problem is more pronounced with Firefox than other browsers. What can be done to load the home page faster? And, in general to load websites? Can someone help? Thank you.

It takes a lot longer than it should to load my home page, MSN. This problem is more pronounced with Firefox than other browsers. What can be done to load the home page faster? And, in general to load websites? Can someone help? Thank you.

Toate răspunsurile (10)

more options

WiFi or plugged in? Who are you using for DNS? https://www.linkedin.com/pulse/how-view-dns-windows-11-3-ways-corusinfotech

Do you have the same issue with Firefox in Troubleshoot Mode?

Here is the add-on I'm using to show load time. see screenshot https://addons.mozilla.org/en-US/firefox/addon/load-time/

Modificat în de jonzn4SUSE

Te-a ajutat?

more options

Hi jazon4SUSE, appreciate your reply. I'm plugged in, no WIFI. The site in question I'm loading is MSN, my home page and my provider is Astound. Yes, still have the extreme load time in safe mode. I've notice when I use a different browser, the load time is shorter and for me to start browsing. Any suggestions as to why the start up load time keeps getting longer? Thank you.

Te-a ajutat?

more options

Do you have the same issue with Firefox in Troubleshoot Mode?

Who are you using for DNS? https://www.linkedin.com/pulse/how-view-dns-windows-11-3-ways-corusinfotech

Te-a ajutat?

more options

Hi jonzn4SUSE, Thank you for your reply. If I got it correct, my DNS is 142.250.217.78. Yes, it still is a issue with safe mode enabled. When I use the browser Chrome, the homepage, which still is MSN loads much faster. Any suggestions? Thank you.

Te-a ajutat?

more options

Time for you to swish & flick a little science to see if that's the best dns for you. The 142 looks like google, but you should run this test and it will show you the best dns for your local. https://www.grc.com/dns/benchmark.htm

Te-a ajutat?

more options

Te-a ajutat?

more options

Google DNS server addresses:

   8.8.8.8 and/or 8.8.4.4 for IPv4.
   2001:4860:4860::8888 and/or 2001:4860:4860::8844 for IPv6.

Te-a ajutat?

more options

Hi jonzn4SUSE, thank you for your reply. There's a lot for me to try in your suggestions. Great! I will try them all, except one. I will first try the DNS test you suggest. I will then try the clearing the browser cache. I had trouble quite some time ago with refreshing Firefox, so I'll take a pass on that for now? Give me a little time to try your suggestions and I will get back to you. Thank you, jonzn4SUSE. Appreciate your help.

Te-a ajutat?

more options

Hi jonzn4SUSE, I executed the clear the browser cache. I think that may have helped? Hard to tell though. When I initially load Firefox it takes 1 minute and 15 seconds to load my homepage. When I use Chrome it takes 20 seconds to load my homepage. Both browsers used the same homepage, MSN. So clearly something is taking Firefox longer to start up and get running. Haven't tried the DNS test yet. But, if my IP address is the same for both Firefox and Chrome I suspect that would not be a issue? Maybe you could explain? I do appreciate your help, jonzn4SUSE.

Te-a ajutat?

more options

Hi jonzn4SUSE, I forgot to mention something. When I try and start Firefox in safe mode my homepage, MSN does NOT appear. So hard to determine if safe mode is telling me anything? But, when I do click on open Firefox in safe mode Firefox opens much faster. But, again safe mode doesn't load my homepage, MSN so hard to tell if that helped? Maybe you could explain? Thanks again, jonzn4SUSE.

Te-a ajutat?

Adresează o întrebare

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.