On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Pesquisar no apoio

Evite burlas no apoio. Nunca iremos solicitar que telefone ou envie uma mensagem de texto para um número de telefone ou que partilhe informações pessoais. Por favor, reporte atividades suspeitas utilizando a opção "Reportar abuso".

Learn More

How do you disable a new tab from opening when a search link is clicked?

  • 7 respostas
  • 97 têm este problema
  • 24 visualizações
  • Última resposta por widnas

more options

It seems like every time I click a link in a search page, whatever the provider, it opens a new tab. I've gone into "about:config" changed the browser.search.tab to "true" without any change. What is with this? The earlier versions of FF allowed me to click a link in Google or where ever and it opened in the same tab. I need help with this issue. Is there a bug no one knows about? I've followed all suggestions on the forums and nothing seems to change. I did find however that "Youtube" links do open in the same tab. Strange!

Please help, getting overloaded with too many tabs.

Erik Ater

It seems like every time I click a link in a search page, whatever the provider, it opens a new tab. I've gone into "about:config" changed the browser.search.tab to "true" without any change. What is with this? The earlier versions of FF allowed me to click a link in Google or where ever and it opened in the same tab. I need help with this issue. Is there a bug no one knows about? I've followed all suggestions on the forums and nothing seems to change. I did find however that "Youtube" links do open in the same tab. Strange! Please help, getting overloaded with too many tabs. Erik Ater

Todas as respostas (7)

more options
  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.

Search this string "browser. link. open_newwindow". Change the value and insert 1. Press ok and restart firefox. Solved?

more options

You can also check the Google Search Settings page.

more options

In my case setting the digit to -1 works. Setting it to 1 does not solve the problem and still gives me a new tab.

more options

Only 1, 2, and 3 are valid values for the browser.link.open_newwindow pref.

  • 1: current tab; 2:new window; 3:new tab;

This pref applies to links opened via JavaScript:

more options

I know this, however when I change back to 1 it does not solve the tab problem. I still get a new tab for every link clicked.

The -1 solution worked for only a few minutes yesterday.

How to solve this problem?

Firefox 27. on Mid-2012 Macbook Pro running OS X 10.9.1

more options

If the link specifies a target window or a generic _blank then Firefox will open the link in a new tab.

For the Google website you can change this behavior in the Google search settings.

more options

Not sure if you will see this but THANK YOU! I was going nuts!