Pesquisar no apoio

Evite burlas no apoio. Nunca iremos solicitar que telefone ou envie uma mensagem de texto para um número de telefone ou que partilhe informações pessoais. Por favor, reporte atividades suspeitas utilizando a opção "Reportar abuso".

Learn More

How do I keep the URL bar from automatically filling in URLs?

  • 4 respostas
  • 15 têm este problema
  • 285 visualizações
  • Última resposta por jcanth

more options

I don't want to disable the drop-down menu. Only filling in the URL bar with the rest of a URL once I start typing it.

I don't want to disable the drop-down menu. Only filling in the URL bar with the rest of a URL once I start typing it.

Solução escolhida

Actually what you want to do is follow the same procedure but set

browser.urlbar.autoFill to false

That stops the url bar filling bit keeps the dropdown menu.

Ler esta resposta no contexto 👍 6

Todas as respostas (4)

more options

Type about:config into your addressbar, press Enter Accept the warning in the search bar on this page, enter browser.urlbar.autocomplete.enabled Double click the Result to change it to False. Restart Firefox.

more options

Changing browser.urlbar.autocomplete.enabled kills both the autocomplete in the URL bar and the suggestions dropdown.

As Lumby, I don't want the auto-complete, but I still want the suggestions dropdown, only because the auto-complete seems never bring anything remotely useful, while the dropdown always bring something in recent history or bookmarked.

more options

Most of the sites I use the dropdown for are links from whatever homepage. The auto-complete just fills in the homepage (e.g., www.website.com) when the link I really want is www.website.com/link/path/etc.

A related issue is that the forced upgrade to Firefox 14.0.1 destroyed my dropdown shortcuts. Typing the two or three keystrokes that used to bring up one website now bring up another, and the website I actually want is either buried in the dropdown menu or gone altogether.

more options

Solução escolhida

Actually what you want to do is follow the same procedure but set

browser.urlbar.autoFill to false

That stops the url bar filling bit keeps the dropdown menu.