On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Pesquisar no apoio

Evite burlas no apoio. Nunca iremos solicitar que telefone ou envie uma mensagem de texto para um número de telefone ou que partilhe informações pessoais. Por favor, reporte atividades suspeitas utilizando a opção "Reportar abuso".

Learn More

Why does my redirect link work when I enter it manually, but not when it's accessed from a link in another site?

more options

I have a website (A) with a link to another page (B). When I put the link for B directly into the address bar, it goes to the page it's supposed to. When I put the hyperlink into the code for A to link to B, clicking on that button goes to a page that has a black background and a single pixel. That incorrect page has the right link in the address bar, but not the page itself.

In case this is needed, A is a presell page that I did not write. B is the affiliate link for an affiliate marketing sales page. When I enter the affiliate link into the address bar and it works, it ends up saying something else in the address bar. Also, I tested it in Internet Explorer and it did work properly there as a link from A to B.

I can provide anything that would help figure this out.

I have a website (A) with a link to another page (B). When I put the link for B directly into the address bar, it goes to the page it's supposed to. When I put the hyperlink into the code for A to link to B, clicking on that button goes to a page that has a black background and a single pixel. That incorrect page has the right link in the address bar, but not the page itself. In case this is needed, A is a presell page that I did not write. B is the affiliate link for an affiliate marketing sales page. When I enter the affiliate link into the address bar and it works, it ends up saying something else in the address bar. Also, I tested it in Internet Explorer and it did work properly there as a link from A to B. I can provide anything that would help figure this out.

Todas as respostas (1)

more options

Hmm, do you use Kaspersky security software? It has a feature called "Anti-Banner" that can redirect certain addresses to a single pixel image.

I'm not familiar with any other software that does that, although there might be some.

Could you check:

Double-check content blockers: Firefox's Tracking Protection feature and extensions that counter ads and tracking may break websites that weren't built to operate normally without the blocked components.

Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: What happened to Tracking Protection?.

Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Test in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?