Pesquisar no apoio

Evite burlas no apoio. Nunca iremos solicitar que telefone ou envie uma mensagem de texto para um número de telefone ou que partilhe informações pessoais. Por favor, reporte atividades suspeitas utilizando a opção "Reportar abuso".

Learn More

In Amazon I get error message that page isn't redirecting properly

  • 8 respostas
  • 8 têm este problema
  • 166 visualizações
  • Última resposta por Phoxuponyou

more options

When I try to display details of an item in Amazon eg a book, I get an error saying Problem loading page. The page isn't redirecting properly Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

An example of the URL causing this problem is https://www.amazon.co.uk/gp/product/0692394028?redirect=true&redirect=true&redirect=true&redirect=true&redirect=true&redirect=true&redirect=true&redirect=true&redirect=true&ref_=gb1h_img_m-3_4447_e77918ec&smid=A3P5ROKL5A1OLE


I've tried a refresh of Firefox, I've tried removing it and re-installing it. I've tried deleting cache and cookies but I still keep getting the same problem. I'm using v42.0.

Any help would be appreciated.

When I try to display details of an item in Amazon eg a book, I get an error saying Problem loading page. The page isn't redirecting properly Firefox has detected that the server is redirecting the request for this address in a way that will never complete. An example of the URL causing this problem is https://www.amazon.co.uk/gp/product/0692394028?redirect=true&redirect=true&redirect=true&redirect=true&redirect=true&redirect=true&redirect=true&redirect=true&redirect=true&ref_=gb1h_img_m-3_4447_e77918ec&smid=A3P5ROKL5A1OLE I've tried a refresh of Firefox, I've tried removing it and re-installing it. I've tried deleting cache and cookies but I still keep getting the same problem. I'm using v42.0. Any help would be appreciated.

Solução escolhida

Thanks for your reply.

However, now that I've got a stable system working I'm not going to try again 42.0 but will wait until a newer version is released. Reverting back to 41.0.2 has also stopped all the site crashes I was experiencing (and reported) with 42.0 - so IMO there are definitely issues with v42.0

Ler esta resposta no contexto 👍 0

Todas as respostas (8)

more options

This issue can be caused by corrupted cookies or cookies that are blocked.

  • check the permissions on the about:permissions page and in "Tools > Page Info > Permissions"

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

See also:

more options

Thank you for your reply.

Cookies is set to allow. I have removed all cookies. I have cleared the cache. The info in the suggested KB doesn't help.

Unfortunately the problem is still present.

more options

Are you using a bookmark or are you starting with the main (home) page of this website?

If you use a bookmark or use a link that has specific GET data appended to the link to open a specific page on the server then try to navigate to that page starting with the main page or the sign in page in case this bookmark or link is currently broken.


Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Modificado por cor-el a

more options

I'm starting with the main homepage of the site.

Unfortunately restarting in safe mode still causes the same problem.

more options

I've reverted to 41.0.2 and the problem has disappeared.

Comment. I've had a LOT of problems with version 42 - mainly crashes which have been reported. I hope a new version is released soon that fixes the issues with 42.0 because as it stands I'm advising against anyone going to version 42.0.

more options

First thing that came to mind was bad settings or profile, but a Refresh should have fixed that. network.http.sendRefererHeader in particular has been previously indicated as a culprit, if it's not set to its default value.

Next is obviously cookies+cache, if this is an isolated case with a particular site, but if you cleared it all (Clear and/or Forget Site) and they are allowed, that's that.

What comes to mind last due to the HTTPS link is security software interference. What software do you use, and does it use browser plug-ins or SSL scanning? If you fancy giving it another burl, you could try without SSL scanning and browser protection components.

Judging by questions I've seen or been part of, 42.0 does not appear to be particularly problematic on Windows 7, but that is just my personal impression.

more options

Solução escolhida

Thanks for your reply.

However, now that I've got a stable system working I'm not going to try again 42.0 but will wait until a newer version is released. Reverting back to 41.0.2 has also stopped all the site crashes I was experiencing (and reported) with 42.0 - so IMO there are definitely issues with v42.0

more options

I fully understand. I'm just here to suggest fixes, hence the interest. Better luck with the next release!