Não consigo adicionar, alterar ou salvar favoritos - Como corrigir

Este artigo explica o que fazer se não conseguir adicionar novos favoritos ou realizar alterações.

Nota: Se você conseguiu adicionar um favorito, mas não o encontra, veja Recuperar Favoritos perdidos ou ausentes.

Não consigo adicionar ou modificar os favoritos

Se você não consegue adicionar novos favoritos ou se as mudanças na barra de ferramentas não são salvas quando você reinicia o Firefox, veja Mudanças nas barras de ferramentas e tamanhos das janelas não são salvos.

Se você não consegue adicionar novos favoritos ou editá-los e você tem uma extensão voltada para os Favoritos instalada (por exemplo, uma que sincronize todos os favoritos), siga as instruções em Solucione problemas com extensões, temas e aceleração de hardware para corrigir problemas comuns do Firefox para determinar se uma extensão está causando o problema.

Eu consigo adicionar ou editar os favoritos, mas eles somem quando eu reinicio o Firefox

Se você consegue adicionar, remover, ajustar e realizar outras mudanças nos seus favoritos, mas suas alterações são perdidas sempre que você reinicia o Firefox, teste estas soluções:

Nota: É recomendável que você desative qualquer extensão para os favoritos, como explicado aqui antes de prosseguir com as sugestões abaixo.

Repare o arquivo dos Favoritos

Se as suas alterações nos Favoritos são descartadas após reiniciar o Firefox, então o arquivo dos Favoritos pode estar protegido contra escrita. Um arquivo protegido contra escrita não pode ser alterado, logo o Firefox não pode salvar as mudanças.

Autorize o Firefox a salvar mudanças nos Favoritos:

  1. Abra a pasta do seu perfil:

    No topo da janela do Firefox, clique no botão Firefox, vá até o menu AjudaNa barra de menus, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Dados para suporte. A aba com os dados para suporte será aberta.Clique no botão New Fx Menu , depois em ajuda Help-29 e então em Dados para suporte. A aba com os dados para suporte será aberta.

  2. Abaixo da seção Informações básicas sobre o aplicativo, clique em Abrir Pastaabrir no FinderAbrir pasta. Uma janela com o seu perfil será aberta.
  3. Nota: Se não conseguir abrir ou usar o Firefox, siga as instruções para encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

    Clique no botão de menu New Fx Menu e clique em SairSair Close 29

  5. Clique com o botão direito no arquivo places.sqlite e selecione Propriedades.
  6. Na janela Propriedades, selecione a aba Geral. Perto da parte inferior da janela, verifique se a opção Somente leitura NÃO está selecionada.

    bookmarksnotsaved-readonly.png

Para ativar a escrita sobre o arquivo dos Favoritos:

  1. Abra a pasta do seu perfil:

    No topo da janela do Firefox, clique no botão Firefox, vá até o menu AjudaNa barra de menus, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Dados para suporte. A aba com os dados para suporte será aberta.Clique no botão New Fx Menu , depois em ajuda Help-29 e então em Dados para suporte. A aba com os dados para suporte será aberta.

  2. Abaixo da seção Informações básicas sobre o aplicativo, clique em Abrir Pastaabrir no FinderAbrir pasta. Uma janela com o seu perfil será aberta.
  3. Nota: Se não conseguir abrir ou usar o Firefox, siga as instruções para encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

    Clique no botão de menu New Fx Menu e clique em SairSair Close 29

  5. Selecione o arquivo places.sqlite.
  6. Na barra de menu selecione Arquivo e selecione Obter Informações. A janela com detalhes de places.sqlite abrirá.
  7. Desmarque a caixa de seleção Bloqueado.

Crie um novo arquivo para os Favoritos

Os favoritos e o histórico de navegação são armazenados na pasta de perfil no Firefox sob o nome places.sqlite. Se houber algum problema com esse arquivo, suas mudanças nos favoritos podem ser perdidas sempre que reiniciar o Firefox. Mas, você pode forçar o Firefox a criar um outro arquivo places.sqlite deletando (ou renomeando) o atual.

Imprima ou anote as próximas instruções antes de executá-las porque você precisará fechar o Firefox para deletar ou renomear os arquivos.

Aviso: Uma vez deletado o arquivo places.sqlite, você perderá todo o histórico de navegação. O Firefox somente mantêm uma cópia deste arquivo para histórico de navegação.
  1. Abra a pasta do seu perfil:

    No topo da janela do Firefox, clique no botão Firefox, vá até o menu AjudaNa barra de menus, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Dados para suporte. A aba com os dados para suporte será aberta.Clique no botão New Fx Menu , depois em ajuda Help-29 e então em Dados para suporte. A aba com os dados para suporte será aberta.

  2. Abaixo da seção Informações básicas sobre o aplicativo, clique em Abrir Pastaabrir no FinderAbrir pasta. Uma janela com o seu perfil será aberta.
  3. Nota: Se não conseguir abrir ou usar o Firefox, siga as instruções para encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

    Clique no botão de menu New Fx Menu e clique em SairSair Close 29

  5. Na pasta do seu perfil, encontre os arquivos places.sqlite e places.sqlite-journal (se existir, e delete-os (ou renomeie por exemplo, para places.sqlite"OLD", para manter o arquivo antigo como cópia de segurança).

O Firefox irá criar um novo arquivo places.sqlite e automaticamente importará os favoritos através da cópia de segurança mais recente. Os seus favoritos terão novas cópias de segurança, mas você perderá seu histórico de navegação. Note que o histórico de navegação é usado pelo recurso de autocompletar na barra de endereços.




Baseado em informações de Bookmarks not saved (mozillaZine KB)


Compartilhe este artigo: http://mzl.la/1xKrIV9

Este artigo foi útil? Por favor, aguarde...

Contribuidores que ajudaram a escrever esse artigo: ouesten, alvarenga, StoneKany, andrelcmarinho. Você também pode ajudar - descubra como.