Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't download pdf's using iMacros "TAG" command

  • 1 balasan
  • 1 ada masalah ini
  • 427 paparan
  • Balasan terakhir oleh dumdidadida

more options

For work, I automated the downloading of documents (doc, docx, pdf files etc.) using a simple macro in iMacros. I had to use a macro because the nature of the site is - go to the main screen, click a client name link, scroll down and click a link to download the document - then go back to the main screen and repeat. The macro automated this tedious process and WAS working with about 95% success (seems that I can't tell firefox to automatically save a txt file for some reason - but that's another story). Now, all of a sudden, the macro won't download any pdf's. The macro still works fine when the document is a doc or docx or rtf file but when it hits a pdf file, it does nothing - just moves on to the next client. Since the macro works properly with the other file types (again, not txt - but everything else) it's probably not an iMacros issue. The frustrating part is - I can go into the page manually where the pdf file lives - and click on the file - and it works properly - file downloads automatically as it should.

the macro code line is very simple: TAG POS=1 TYPE=A ATTR=TARGET:_blank

I had to set all my document file types to automatically download (including adobe files) when a link is clicked - which is fine - and like I said - the macro used to work - just stopped downloading pdf's all of a sudden.

Also I disable the adobe plugin - but that didn't work - since I have adobe files set to download automatically it shouldn't make a difference if the plugin is active or not anyway.

Any help appreciated, Thanks

All Replies (1)

more options


As a safe test you can try installing iMacros in a new profile and check. The iMacros support would also be helpful.