Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Camera grants turned of following installation of Firefox 67

  • 2 balasan
  • 1 ada masalah ini
  • 22 paparan
  • Balasan terakhir oleh Mark Ansel

more options

I regularly use a video chatting site. Through Firefox 66, my Logitech USB web cam worked fine at that site.

However, following installation of Firefox 67, each time I attempt to use my cam at that site, I receive a message that says, "Error: Camera Grants Off".

I already have checked the Privacy and Security Settings in Firefox 67 and confirmed that site has camera access enabled. Nevertheless, my cam won't work at that site anymore.

Incidentally, my cam works fine at that site when I use either Edge or Opera browsers. But for other reasons, I still would prefer using Firefox at that site.

Has anyone any ideas as to how I can correct this behavior?

I regularly use a video chatting site. Through Firefox 66, my Logitech USB web cam worked fine at that site. However, following installation of Firefox 67, each time I attempt to use my cam at that site, I receive a message that says, "Error: Camera Grants Off". I already have checked the Privacy and Security Settings in Firefox 67 and confirmed that site has camera access enabled. Nevertheless, my cam won't work at that site anymore. Incidentally, my cam works fine at that site when I use either Edge or Opera browsers. But for other reasons, I still would prefer using Firefox at that site. Has anyone any ideas as to how I can correct this behavior?

All Replies (2)

more options

Hi Longhornmark, does Firefox only have a problem on that site, or are other sites unable to access the camera as well?

"Captain Anonymous" has a demo online here: https://codepen.io/anon/pen/gpmPzm (a Mozilla article linked to this page, so hopefully that means it's safe).

Hopefully you'll get the permission prompt --

<center></center>

-- and then click the Start button and let it record for a while before clicking Stop.

more options

My answer to your question is I don't know, JScher, because that site is the only one at which I use my web cam. On the other hand, I can say this: When I connect my web cam to either of my other two PCs and use Firefox 67 on either machine, the cam does broadcast my image to my correspondent. In other words, this problem is unique to one machine, but only with Firefox 67 on that machine... not Firefox 66.0.3, not Edge, and not Opera.

However, I was able to connect to that anonymous pen. And it was able to access my Logitech web cam.

Now I've signed in to the chatting site at which I use my cam. And cam rights have been granted! So, my cam seems to work at that site again. Thank you!