Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Need clearer information about system requirements

  • 2 balasan
  • 4 ada masalah ini
  • 13 paparan
  • Balasan terakhir oleh James

more options

I'm running Firefox 43.0.1 on 32-bit Windows XP SP3 without any problem. Firefox keeps nudging me to update to 44.0.2, but system requirements for that version specify Windows XP SP2. I'm not clear whether SP2 is the minimum required, or if it means SP3 isn't supported.

If it turns out SP3 is NOT supported and I can no longer update Firefox, is there any way to turn off notifications about updating?

I'm running Firefox 43.0.1 on 32-bit Windows XP SP3 without any problem. Firefox keeps nudging me to update to 44.0.2, but system requirements for that version specify Windows XP SP2. I'm not clear whether SP2 is the minimum required, or if it means SP3 isn't supported. If it turns out SP3 is NOT supported and I can no longer update Firefox, is there any way to turn off notifications about updating?

All Replies (2)

more options

I am sure it means SP2 as a minimum, and I know for fact SP3 works as I have Firefox on such an XP.

You should update to Fx44 and in a few days time Fx45.

more options

The system requirements page mentions the minimum for each of the OS's. When it says WinXP SP2 it means SP2 and newer which is SP3. Same with Windows 8 it means 8.0 and 8.1.

It is best to have SP3 to be more secure on WinXP which has been EOL life since April 2014.

The reason you were served 43.0.1 when you downloaded Firefox is because 43.0.2 and newer setups on Windows is signed now in which you need WinXP SP3 to install. Since the web browser useragents on WinXP does not show if they have SP2 or SP3 installed it was decided to serve a Firefox version WinXP users can install and then update to current Release from.