Kenapa plugin Java, Silverlight, Adobe Acrobat dan plugin lain tidak lagi berfungsi?

Sokongan plugin NPAPI dalam Firefox kecuali Adobe Flash ditamatkan pada Mac 2017, apabila Firefox versi 52 dikeluarkan.Bermula dengan Firefox versi 52, sokongan untuk plugin NPAPI dalam Firefox telah ditamatkan, kecuali Adobe Flash. Beberapa plugin yang tidak lagi dimuatkan ialah Java, Microsoft Silverlight dan Adobe Acrobat. Lihat dokumen keserasian ini untuk butirannya.

Selama beberapa tahun lepas, Firefox telah membangunkan pelbagai API Web supaya laman web boleh melaksanakan perkara yang sama tanpa plugin, jadi anda tidak akan rasa sebarang perubahan dalam pengalaman pelayaran anda.

Kenapa Firefox melakukannya?

Internet dipenuhi dengan laman web yang bukan lagi halaman statik, seperti video, bunyian dan permainan. Plugin NPAPI, terutamanya Flash, telah membantu mendayakan halaman interaktif ini. Tetapi, plugin juga menyebabkan pelayaran menjadi semakin perlahan, kurang selamat dan cenderung untuk ranap.

Selama beberapa tahun lepas, Firefox telah berusaha keras untuk membangunkan pengganti plugins. Semuanya dikenali sebagai API Web. API Web direka untuk menggantikan fungsi plugin tanpa mengabaikan keselamatan, kestabilan dan prestasi internet.

Sebelum API Web ini siap sepenuhnya, Firefox memulakan peralihan apabila plugin dimuatkan secara manual dengan (klik untuk mengaktifkan).

Sekarang, semua sudah siap. Banyak laman yang sudah menyesuaikannya, dan hampir semua halaman kegemaran anda menikmatinya tanpa plugin yang lama dan tidak selamat. Firefox sudah menjadi pelayar moden, seperti Google Chrome dan Microsoft Edge yang tidak lagi menyediakan sokongan untuk plugin NPAPI.

Saya ada masalah

Jika anda masih belum bersedia dengan peralihan ini, ESR, iaitu (Keluaran Sokongan Lanjutan) Firefox 52 akan terus menyokong plugin tersebut sehingga awal 2018. Klik di sini untuk memuat turun Firefox ESR.

Penting: Firefox versi 52 ESR untuk Windows 64-bit hanya menyokong plugin Adobe Flash dan Microsoft Silverlight. Jika anda perlukan plugin untuk Java atau plugin lain, pilih muat turun Windows (32-bit).

Secara piawai, Firefox 52 ESR akan menggunakan data profil pengguna yang sama seperti versi Firefox yang lain. Pemasangan Firefox 52 ESR selepas menggunakan Firefox versi 55 atau ke atas, akan menyebabkan masalah, seperti mesej ralat, terputus sambungan dalam beberapa bahagian Firefox dan isu dengan laman web. Anda perlu samada mencipta profil baru untuk digunakan dalam Firefox 52 ESR atau memuat semula Firefox selepas memasang Firefox 52 ESR.
// Sukarelawan budiman berikut telah membantu menulis artikel ini:Othman Wagiman. Anda juga boleh membantu - ketahui caranya.

Artikel ini bermanfaat? Sila tunggu...

Sukarelawan Sokongan Mozilla