Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Getting this error on Ancestry.com web site: Yahoo.widget.Overlay is not a constructor, Ancestry advises me that you will need to fix due to Win7 update

  • 1 reply
  • 1 has this problem
  • 46 views
  • Last reply by user709721

more options

The last 2 days when I log into Ancestry.com from my desktop computer, the home page gives me an error message of "Yahoo.widget.overlay is not a constructor". I've called Ancestry's help line and they inform me that other Ancestry customer's are having the same issue with Firefox browser. They further said that there was a Windows7 update and that Firefox will have to fix this issue for sites that use widgets such as Ancestry.com. I do not have this issue when I use Internet Explorer to access Ancestry.com. I prefer to use Firefox, so please fix as soon as possible.

Thank you for your assistance.

The last 2 days when I log into Ancestry.com from my desktop computer, the home page gives me an error message of "Yahoo.widget.overlay is not a constructor". I've called Ancestry's help line and they inform me that other Ancestry customer's are having the same issue with Firefox browser. They further said that there was a Windows7 update and that Firefox will have to fix this issue for sites that use widgets such as Ancestry.com. I do not have this issue when I use Internet Explorer to access Ancestry.com. I prefer to use Firefox, so please fix as soon as possible. Thank you for your assistance.

All Replies (1)

more options

Hello,

Could you try disabling JavaScript?

In Firefox 23, as part of an effort to simplify the Firefox options set and protect users from unintentially damaging their Firefox, the option to disable JavaScript was removed from the Firefox Options window.

However, the option to disable JavaScript was not removed from Firefox entirely. You can still access it from about:config or by installing an add-on.

about:config

  1. In the address bar, type "about:config" (with no quotes), and press Enter.
  2. Click "I'll be careful, I promise"
  3. In the search bar, search for "javascript.enabled" (with no quotes).
  4. Right click the result named "javascript.enabled" and click "Toggle". JavaScript is now disabled.

To Re-enable JavaScript if this doesn't work, repeat these steps.

If this works, you can install an add-on that lets you disable JavaScript and re-enable it on the fly without going through about:config such as

  • No-Script (to disable JavaScript on a per page basis, as required)
  • QuickJava (to easily disable and enable JavaScript, automatic loading of images, and other content)
  • SettingSanity (adds back removed options for JavaScript, Advanced JavaScript Settings, loading images, and showing the Tab Bar)

Hope this helps!

Curtis