Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have Firefox 101 set to open previous session tabs but it does not.

  • 8 replies
  • 2 have this problem
  • 33 views
  • Last reply by cor-el

more options

I have Firefox 101. It is set to open previous session tabs but it does not. Further I am not able to retrieve the ones I used to have available when I open Firefox. I have not cleared the history.

I have Firefox 101. It is set to open previous session tabs but it does not. Further I am not able to retrieve the ones I used to have available when I open Firefox. I have not cleared the history.

Chosen solution

So here is the resolution I found that worked. Working in Windows 10, When all the tabs are gone, open task manager (control-alt-delete) In my case I found 9 FF sessions open, I closed all of them then shut down the computer fully. Now when I open FF everything is as it should be. All Tabs that I like to have available are there. I fist tried this fix without shutting down the computer but it solved the problem only temporarily.

Read this answer in context 👍 0

All Replies (8)

more options

Hi david.dala, Are you using Private Browsing or are you in "always use Private Browsing mode"?

more options

I don't usually use private mode but did this one time and then regular mode was gone. Even though I had my settings set to restore previous tabs on open, Firefox would only open in a single tab. I did some research and tried to fix the problem by creating a sessionstore.jsonlz4 file as instructed from a Redit post ( https://www.reddit.com/r/firefox/comments/56sevb/how_to_restore_a_browsing_session_from_backup/ ) but the problem persisted even after doing a soft and full shut down. Now, after clicking this email link to respond ti your question, all my tabs are back. Nice work buddy! Thanks (smile) Don't know how the problem happened or how it was fixed so that's still a concern.

more options

What do you have set here. see screenshots

more options

Please take a look at this thread - https://support.mozilla.org/en-US/questions/1239293 especially cor-el's response regarding Verify Integrity

more options

I noticed the problem was back again where when I click on the Firefox icon in the task bar it comes up with no saved tabs. To fix it I opened firefox from the link in the email and all my tabs were back again. Interestingly, Firefox opened from the left side of my screen. I'm guessing I may have closed Firefox by sliding it to the left one night when I was falling asleep. This is somehow related to the problem.

more options

Chosen Solution

So here is the resolution I found that worked. Working in Windows 10, When all the tabs are gone, open task manager (control-alt-delete) In my case I found 9 FF sessions open, I closed all of them then shut down the computer fully. Now when I open FF everything is as it should be. All Tabs that I like to have available are there. I fist tried this fix without shutting down the computer but it solved the problem only temporarily.

more options

this solved the issue for me. after months of FF buggin' me to upgrade, I did and they it wouldn't reload my old tabs upon startup. i wonder how i can be sure when i close, it will reopen them. i guess i have to close FF via the task manager, ugh

more options

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox Title bar, especially if you have multiple windows open to prevent losing tabs in unnoticed windows.

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

Note that if you let the OS close Firefox then results can be intermittent as it can take unknown time to close Firefox, especially if you use "Clear history when Firefox closes".