Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does cursor/focus select the address bar when clicking into a new page?

  • 3 replies
  • 6 have this problem
  • 903 views
  • Last reply by ssj2Oshi

more options

It doesn't happen all time but most of the time... When i am navigating a site by clicking on links, whenever a new page loads the address bar will be selected to start typing. when i go to scroll down (using arrow keys/page down) it will instead scroll through recent page URLS in the address bar, instead of scrolling down the page. Seems like this behavior just started today...

To be clear this is not anything to do with tabs, opening pages in the same tab by left clicking on links also sets the cursor to address bar.

I don't believe i am in safe mode, I have tried resetting firefox and this still occurs. If this is working as intended, can i turn it off?

Chosen solution

Are you opening the links in the same tab?

Does this also happen if you middle-click the link to open the link in a new tab?

Did you check for issues caused by plugins?


In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (localstore-safe.rdf file)
  • JavaScript JIT compilers are disabled (about:config page: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected
Read this answer in context 👍 0

All Replies (3)

more options

I got out of it by tabbing right then all the way to the end of the toolbar and into the webpage. It is possible to remove elements in the toolbar to create less button pressing.

Can you turn it off? Not sure, could not find the right entry in about:config

If it does not scroll, please make sure smooth scrolling is turned on: , go to Options > Advanced. In the General tab, checkmark "Use Smooth Scrolling".

more options

Chosen Solution

Are you opening the links in the same tab?

Does this also happen if you middle-click the link to open the link in a new tab?

Did you check for issues caused by plugins?


In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (localstore-safe.rdf file)
  • JavaScript JIT compilers are disabled (about:config page: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected
more options

I installed the beta version of 31.0 over 30.0 and it seems to have "fixed" the issue.

As mentioned, before doing that i had tried resetting firefox to the defaults through the troubleshooting menu, no extensions installed and it still occurred.

But yes, this was happening when opening links in the same tab with left click. even clicking search results in google had this effect.