Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't get to Amazon without adding the scrambled letters or order from this browser. I tried turnig off add on. That did not help. It worked for years and a few weeks ago it just went nuts. Works fine on Edge.

  • 2 replies
  • 1 has this problem
  • 7 views
  • Last reply by cor-el

more options

Amazon stopped working a few weeks ago. Now it wants me to put in the scrambled letters to sign in and it will not let me purchase anything. I tried turning off add ons that did not change it. It works fine on other browsers.

Amazon stopped working a few weeks ago. Now it wants me to put in the scrambled letters to sign in and it will not let me purchase anything. I tried turning off add ons that did not change it. It works fine on other browsers.

All Replies (2)

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

The System Details list shows you run an older Firefox version that is no longer supported with security updates.

  • Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv: 80.0) Gecko/20100101 Firefox/80.0

Any specific reason you use such an old version as that old version might be causing issues ?

Could you please update to the current Firefox 94.0 release.