Search Support

How Come So Much Memory Usage

  • 20 replies
  • 5 have this problem
  • 6646 views
  • Last reply by FredMcD

more options

Windows 7 64-bit Desktop. Firefox 58.0.2

I had 3 tabs open. While browsing my computer slowed to a crawl. I have experienced this many times. Even disabled my two addons with the same result. What can I do?

See the screenshot.

Attached screenshots

Chosen solution

Thanks for your last reply. I have done some further research. I have 3 browsers installed: Internet Explorer, Chrome and Firefox. I found the excessive RAM usage 2+ GB on all three browsers. Therefor, the issue is not the fault of Firefox. My research was with one particular web site. I ran another test opening multiple tabs without that particular web site and experienced no extremely high RAM usage. With four tabs open, the highest was about 250 MB. This in itself is high but nowhere close to 2+ GB. The problem is with one particular web site. I will follow up with them on a resolution. Thanks for all your in depth help.

Read this answer in context 👍 0

All Replies (20)

more options
more options

I will try this and report back. One Question. If I have multiple tabs open, should I close them before going to Safe Mode?

more options

Firefox has to be shut down and restarted.

more options

I started Firefox in Safe Mode, opened two tabs and after 30 minutes I got the results attached.

more options

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

more options

I ran about:config and there was only one browser.tabs.remote.autostart. No browser.tabs.remote autostart.2. I changed it to false. When restarting firefox, there was only one instance of firefox.exe and it immediately went to 700MB and increased to 800MB+ with two tabs open.

more options

I called for more help.

more options

OK. Thanks. I really appreciate your help.

more options

You could try this please : Go the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please.

Note : Acceleration is for your Video Card, monitor to see if need to turn back on.

Please let us know if this solved your issue or if need further assistance

more options

Please also use Microsoft Disk Cleanup. Run it then run again and choose Clean System Files, should be run weekly.

Defrag monthly.

https://support.microsoft.com/en-ca/help/15055/windows-7-optimize-windows-better-performance

If have room on your Hard Drive : MICROSOFT VIRTUAL MEMORY

You may want to try this: Open the System Folder then Click on left side Advanced System Settings which opens System Properties click the Advanced Tab then click Performance button Settings then the Advanced Tab then Click the Change under Virtual Memory click Custom Size and Change Size to where it says Recommended Size then Click Set and then Click Apply then please Re-boot. Put the MAX number in both fields, min & max

System - -> Advanced System Settings --> System Properties - -> Advanced Tab - -> Change Virtual Memory - -> Custom Size - -> ENTER Recommended Size - -> Set - -> Apply-- > Reboot

Please let us know if this solved your issue or if need further assistance.

more options

I'm at "Custom Size" There are two empty fields. Initial size (MB) and Maximum size (MB). I see at the bottom Total paging file size for all drives: Minimum allowed: 16 MB, Recommended: 11841 MB and Currently allocated: 7894 MB. What quantities do I add to each empty field?

Thanks

more options

rwmol said

I'm at "Custom Size" There are two empty fields. Initial size (MB) and Maximum size (MB). I see at the bottom Total paging file size for all drives: Minimum allowed: 16 MB, Recommended: 11841 MB and Currently allocated: 7894 MB. What quantities do I add to each empty field? Thanks

11841 in both Min and Max fields

more options

After the change in Virtual Memory one instance of firefox.exe is now running at 1.7 GB. It's worse now. What else, if anything, can I do?

more options

Hi, sorry to hear. Could be a memory leak or....... Give it more ram is actually a good thing if have the ram to spare and it is not crashing you or slowing it down. https://www.howtogeek.com/334594/stop-complaining-that-your-browser-uses-lots-of-ram-its-a-good-thing/

2 things can try. You can move to the Extended Release Version 52.6.0 ESR. It will continue to get security updates until May 2018, and you can download and install it from this page: *https://www.mozilla.org/en-US/firefox/organizations/all/ Note : Legacy Extensions will be deleted or removed in any version update after May 2018.

You should make a backup of your Profile before going back and just because:

Or can try : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's(Win10)) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 58.0.2 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

more options

Chosen Solution

Thanks for your last reply. I have done some further research. I have 3 browsers installed: Internet Explorer, Chrome and Firefox. I found the excessive RAM usage 2+ GB on all three browsers. Therefor, the issue is not the fault of Firefox. My research was with one particular web site. I ran another test opening multiple tabs without that particular web site and experienced no extremely high RAM usage. With four tabs open, the highest was about 250 MB. This in itself is high but nowhere close to 2+ GB. The problem is with one particular web site. I will follow up with them on a resolution. Thanks for all your in depth help.

more options

Please provide public link(s) (no password) that we can check out. No Personal Information Please !

more options

Sure. I'm an avid user of Ancestry.com. They own the parent web site Find-A-Grave. When going to a specific individuals Find-A-Grave, the RAM spikes.

https://www.findagrave.com

more options

While I noticed a jump on my CPU gadget, it was nothing serious.

more options

If you open just the web site there is not much change. Try opening these three links in separate tabs. Mine spikes to 900 MB.:

https://www.findagrave.com/memorial/49234089

https://www.findagrave.com/memorial/48818560

https://www.findagrave.com/memorial/24470132

more options

No problem found. No memory issues.