Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New windows in Firefox 29 on Windows 8.1 don't open fully maximized when clicked through a link

  • 58 replies
  • 146 have this problem
  • 2807 views
  • Last reply by Novgorod

more options

New problem in firefox 29:

When I click a link that opens the new page in a new window, the window pops open in the last partially maximized state that it was in. Should I maximize the new window (in Windows 8.1) and close it and re-click the original link, the window opens again in the partially maximized state, not the last fully maximized state that I previously closed it in.

To create it as I've encountered it:

-go to https://news.google.com

-click on any article. the default behavior should be to open the article in a new window

-the window won't be maximized in my experience

-you can maximize the window and then close the window/ article

-re-click on the same article and the new window should appear again in the non-maximized state, not the fully maximized state that you closed it in previously


One point of note. Right-clicking the same link that opens the new window and specifically choosing "Open Link in New Window" DOES open the new window in a fully maximized state. I repeat, the new window does open fully maximized when you choose "Open Link in New Window" from the right-click drop downs menu. But, this doesn't happen with the simple left-click, which I'm concerned with.

Modified by bolcrom

All Replies (20)

more options

I have the same problem, anyone have a fix???

more options

v30 still faced the same problem no fix.

more options

This is starting to irritate me...

more options

Me too, no change to this problem with v30.

more options

To fix this issue go into Customize and toggle "Title Bar" in the lower left corner.

This fixed the non-maximize problem on 2 computers for me.

more options

It didn't work.

more options

Try it on version 30 instead of 29. No guarantees, just what I found worked on my computers.

more options

it helps only if you have tabs! if you deactivated tabs, it doesn't work! that's old knowledge though, since they first screwed up the FF windows in version 29...

more options

Is it still screwed up?

more options

yes, and it will stay so forever and ever, because windows 8 is soooo fancy... :-/

more options

I don't use Win 8. I hate it. I use Win 7 and it was doing the same thing in it.

more options

that's kind of what I wanted to say - they think win 8 is so fancy that they HAVE to go for this titlebar-less crap (for no particular reason other than win 8 "corporate design") which screws up everything for everyone else, including win 8 using "classic" settings (titlebar, no tabs etc.)..

the funny thing is that this kind of bug most likely can be solved by setting the right flag somewhere - but they just don't bother spending the 5 minutes to just goddamn look into it... thanks mozilla!

more options

I just tried it in FF 31 and it's working for me!

more options

For me, Win7 and FF31 still has the problem.

To fix these issue non-maximize windows. 1. Disable "Hide Tab Bar With One Tab" addon. 2. Disable Titlebar.

more options

I also have Win 7, FF 31, and "Hide Tab Bar With One Tab", but I don't have the add-on disabled, and now I'm not the having maximize issue.

more options

It look like that they don't want us to use Titlebar anymore And force us to use Tab.

more options

I'm not having any problem now, so I don't know why you are.

more options

"To fix this issue go into Customize and toggle "Title Bar" in the lower left corner. "

This fixed the issue for me. I have vista and firefox 31. I don't use tabs.

more options

Yeah, FINALLY this STUPID and UNNECESSARY bug was FIXED in FF31! The behavior now is the same as in the last working version (28?).. It works with title bar enabled and the "Hide Tab Bar With One Tab" addon (tested on Win7 only).. Opening a link in a new window now correctly duplicates the state of the window from which it was opened (also correctly maximized if the parent window was maximized)..

THANKS (not)... O_o

Modified by Novgorod

more options

So sad. Mine still didn't work. I use classic theme restore to hide one tab bar. It didn't remember maximize state but show with border. H scrollbar also invalid.

I still have to hide Titlebar.

  1. 1
  2. 2
  3. 3