X
Tap here to go to the mobile version of the site.

Support Forum

I cannot change the value in about:newtab from "newtab" to "blank." The dialog is displayed but when I click Ok, the value is not changed.

Posted

I cannot change the value in about:newtab from "newtab" to "blank." The dialog is displayed but when I click Ok, the value is not changed.


Answer

Comment on usual method and solution, by a forum Moderator.

As long as there are no confounding factors, such as certain extensions, or a user.jsfile the procedure is as follows

  1. Open a new tab and type "about:config" in the address bar.
  2. In the Search bar type: "newtab"
  3. Locate and double click "browser.newtab.url"
  4. In the "Enter String Value" box change "about:newtab" to "about:blank" and click OK.
  5. Verify that the value has changed and now all new tabs will be blank.

See post under by pirate048 /questions/976589?page=2#answer-509482 ~J99

I cannot change the value in about:newtab from "newtab" to "blank." The dialog is displayed but when I click Ok, the value is not changed. -------- ===Answer=== Comment on usual method and solution, by a forum Moderator. As long as there are no confounding factors, such as certain extensions, or a user.jsfile the procedure is as follows # Open a new tab and type "about:config" in the address bar. # In the Search bar type: "newtab" # Locate and double click "browser.newtab.url" # In the "Enter String Value" box change "'''about:newtab'''" to "'''about:blank'''" and click OK. # Verify that the value has changed and now all new tabs will be blank. See post under by ''pirate048'' [/questions/976589?page=2#answer-509482] ~J99

Modified by John99

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05

Application

  • Firefox 25.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
  • Support URL: https://support.mozilla.org/1/firefox/25.0/WINNT/en-US/

Extensions

  • AccelerateTab 1.3.1 (speeddial@instair.net)
  • Advanced SystemCare Surfing Protection 1.0 (ascsurfingprotection@iobit.com)
  • Google Analytics Opt-out Browser Add-on 0.9.6 ({6d96bb5e-1175-4ebf-8ab5-5f56f1c79f65})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • AD Block 1.0.0 (searchads@instair.net) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 9800 GT
  • adapterDescription2:
  • adapterDeviceID: 0x0614
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 6-21-2013
  • driverDate2:
  • driverVersion: 9.18.13.2049
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 9800 GT Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.memory.capacity: 65536
  • browser.display.show_image_placeholders: True
  • browser.places.smartBookmarksVersion: 4
  • browser.search.param.yahoo-fr: chr-greentree_ff&ilc=12&type=902615
  • browser.search.useDBForOrder: True
  • browser.sessionstore.max_tabs_undo: 0
  • browser.sessionstore.max_windows_undo: 0
  • browser.sessionstore.resume_from_crash: False
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131025151332
  • browser.startup.homepage: https://ixquick.com/
  • browser.startup.homepage_override.buildID: 20131025151332
  • browser.startup.homepage_override.mstone: 25.0
  • browser.urlbar.autocomplete.enabled: True
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 25.0
  • gfx.direct3d.checkDX10: False
  • gfx.direct3d.last_used_feature_level_idx: 1
  • network.cookie.prefsMigrated: True
  • network.http.max-connections: 48
  • network.http.max-connections-per-server: 16
  • network.http.max-persistent-connections-per-proxy: 16
  • network.http.max-persistent-connections-per-server: 8
  • network.http.pipelining.maxrequests: 8
  • network.http.request.max-start-delay: 0
  • places.database.lastMaintenance: 1383670712
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types:
  • plugin.expose_full_path: True
  • plugin.importedState: True
  • plugin.state.npctrl: 0
  • plugin.state.npgoogleupdate: 0
  • privacy.cpd.cookies: False
  • privacy.cpd.offlineApps: True
  • privacy.cpd.sessions: False
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1382198083

Misc

  • User JS: Yes
  • Accessibility: No
Curtis Parfitt-Ford 33 solutions 363 answers

Hi,

Try using the Settings window to change the preference rather than about:config.

Hope this helps!

Curtis

Hi, Try using the Settings window to change the preference rather than about:config. Hope this helps! Curtis

Question owner

Thanks. Where do I find the Settings window, please? I've looked at every tab and dialog in Tools > Options to no avail.

Thanks. Where do I find the Settings window, please? I've looked at every tab and dialog in Tools > Options to no avail.
Curtis Parfitt-Ford 33 solutions 363 answers

Hi,

Hope this helps!

Curtis

Hi, [[Video:https://www.youtube.com/watch?v=PBHwhXUnNDg]] Hope this helps! Curtis

Question owner

I appreciate the help but that doesn't address my problem. When I open a new tab from an existing Firefox session, I want the new tab to be completely empty when I open it, like it has been for years. I don't want to see thumbnails of web pages I don't want to visit. I don't want to see a theme button for selecting themes I don't want. I don't want search dialogs from search engines I don't use. I just want a new table with a blank content area.

I tried following the only instructions I found and that's when I ran into the problem saving changes to about.config.

I appreciate the help but that doesn't address my problem. When I open a new tab from an existing Firefox session, I want the new tab to be completely empty when I open it, like it has been for years. I don't want to see thumbnails of web pages I don't want to visit. I don't want to see a theme button for selecting themes I don't want. I don't want search dialogs from search engines I don't use. I just want a new table with a blank content area. I tried following the only instructions I found and that's when I ran into the problem saving changes to about.config.
Curtis Parfitt-Ford 33 solutions 363 answers

Hi,

In which case:

  1. At the top of the Firefox window, click on the Firefox button and then select Options
  2. Select the General panel.
  3. Set the Home Page field to "about:blank" ( without quotes ).

Hope this helps!

Curtis

Hi, In which case: # At the top of the Firefox window, click on the Firefox button and then select Options # Select the General panel. # Set the Home Page field to "about:blank" ( without quotes ). Hope this helps! Curtis

Question owner

Yes, that does help. Thanks. :)

That will work until I figure out the bigger picture problem.

Be well,

Mark

Yes, that does help. Thanks. :) That will work until I figure out the bigger picture problem. Be well, Mark
Curtis Parfitt-Ford 33 solutions 363 answers

Hi,

Please mark my answer as the solution if it solved the problem to let my volunteer colleagues know that this question is solved!

Thanks!

Curtis

Hi, Please mark my answer as the solution if it solved the problem to let my volunteer colleagues know that this question is solved! Thanks! Curtis
Curtis Parfitt-Ford 33 solutions 363 answers

Hi,

You could also see How to fix preferences that won't save.

Hope this helps!

Curtis

Hi, You could also see [[How to fix preferences that won't save]]. Hope this helps! Curtis

Question owner

I'd like to keep it up to see if anyone else has any ideas. There's a workaround on the table but it's not what I would call a solution. No offense.

Thanks,

Mark.

I'd like to keep it up to see if anyone else has any ideas. There's a workaround on the table but it's not what I would call a solution. No offense. Thanks, Mark.
Curtis Parfitt-Ford 33 solutions 363 answers
How about https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save?

Question owner

Nothing seems to be working so I'm going to save my bookmarks and reset the whole kit & kaboodle.

Thanks

Mark

Nothing seems to be working so I'm going to save my bookmarks and reset the whole kit & kaboodle. Thanks Mark
Curtis Parfitt-Ford 33 solutions 363 answers

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information.
Note: This will cause you to lose any Extensions and some Preferences.

  • Open websites will not be saved in Firefox versions lower than 25.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Hope this helps!

Curtis

Hello, The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. <br> '''Note''': ''This will cause you to lose any Extensions and some Preferences.'' *Open websites will not be saved in Firefox versions lower than 25. To Reset Firefox do the following: #Go to Firefox > Help > Troubleshooting Information. #Click the "Reset Firefox" button. #Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish. #Firefox will open with all factory defaults applied. Further information can be found in the [[Reset Firefox – easily fix most problems]] article. Did this fix your problems? Please report back to us! Hope this helps! Curtis
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

Note that your System Details List shows that you have a user.js file in the profile folder to initialize some prefs on each start of Firefox.

The user.js file is only present if you or other software has created it, so normally it wouldn't be there. you can check its content with a plain text editor if you didn't create this file yourself.

The user.js file is read each time you start Firefox and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the prefs.js file and possible numbered prefs-##.js and user.js files to reset all prefs to the default value.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

Note that Windows hides some file extensions by default. Among them are .html and .ini and .js and .txt, so you may only see a name without file extension. You can see the real file extension (type) if you open the Properties of the file via the right-click context menu.

See also:

Note that your System Details List shows that you have a user.js file in the profile folder to initialize some prefs on each start of Firefox. The user.js file is only present if you or other software has created it, so normally it wouldn't be there. you can check its content with a plain text editor if you didn't create this file yourself. The user.js file is read each time you start Firefox and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session. You can delete the prefs.js file and possible numbered prefs-##.js and user.js files to reset all prefs to the default value. You can use this button to go to the Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) Note that Windows hides some file extensions by default. Among them are .html and .ini and .js and .txt, so you may only see a name without file extension. You can see the real file extension (type) if you open the Properties of the file via the right-click context menu. See also: *http://kb.mozillazine.org/Preferences_not_saved
John 0 solutions 37 answers

I have this problem. I have tried the about:config route to no avail..the change to blank cannot be made. I have tried clicking on the Firefox icon but don't find the necessary item..maybe because i have Firefox set up with a 'conventional' layout that I much prefer (why do we have unnecessary changes??). All I can find in the Tools: Options section is a method of fixing the first tab.. What next? The squares are really annoying..I don't want them! Help!

I have this problem. I have tried the about:config route to no avail..the change to blank cannot be made. I have tried clicking on the Firefox icon but don't find the necessary item..maybe because i have Firefox set up with a 'conventional' layout that I much prefer (why do we have unnecessary changes??). All I can find in the Tools: Options section is a method of fixing the first tab.. What next? The squares are really annoying..I don't want them! Help!
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

What is the current value of the browser.newtab.url pref on the about:config page?

Is that the default (about:newtab)?

What happens if you double-click the browser.newtab.url pref and change the value to about:blank?

What is the current value of the browser.newtab.url pref on the <b>about:config</b> page? Is that the default (about:newtab)? What happens if you double-click the browser.newtab.url pref and change the value to about:blank?
John 0 solutions 37 answers

It is the default value..about:newtab. I have tried double clicking, as you suggest. I have tried to insert about:blank but the value refuses to change.

It is the default value..about:newtab. I have tried double clicking, as you suggest. I have tried to insert about:blank but the value refuses to change.
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

If you do not keep changes after a restart or otherwise have problems with preferences, see:

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes If you do not keep changes after a restart or otherwise have problems with preferences, see: *http://kb.mozillazine.org/Preferences_not_saved
John 0 solutions 37 answers

I have started in Safe mode. I could then change about:newtab to about:blank but once restarted in 'normal' mode, the changes were lost. Again I could not change about:newtab to about:blank. I have tried to search for prefs:js but can find no prefs with js attached in my Profile folder... Stuck!

I have started in Safe mode. I could then change about:newtab to about:blank but once restarted in 'normal' mode, the changes were lost. Again I could not change about:newtab to about:blank. I have tried to search for prefs:js but can find no prefs with js attached in my Profile folder... Stuck!

Helpful Reply

FYI: I've given up on this issue. I wasted as much time on it as I was willing to waste and just added it to the long, long, long, long list of stupid, sucky, idiotic crap that passes for software in the 21st Century. For about the 10,000th time this month, the answer is to just deal with it because there's no way to solve the non-stop onslaught of useless changes being made just so marketing departments can have new features to advertise.

If software developers spent a hundredth as much time trying to figure out how to help us as they do taking over our computer screen real estate for advertising their crap, trying to manipulate us, and attempting to force us to do everything they way the developer prefers to do things, maybe we could get some work done without having to waste so much time on this type of crap.

I will never get back the thousands of hours of my life that have been wasted trying to undo some ridiculous change that some idiot in a cubicle somewhere decided that I have to have so badly that there's no way to prevent it from taking over my desktop.

Thanks for trying to help. The problem isn't with your willingness to help but I'm done anyway. I have no more of my life to waste on yet another piece of crap software that thinks it knows better than I do how I want to use my own computer.

I mean, come on, man. All I want is a blank page when I click the new tab control but look how it is practically impossible to achieve even with so many smart people trying to do it. We were better off with monochrome monitors and text-based applications; we got a heck of a lot more work done.

FYI: I've given up on this issue. I wasted as much time on it as I was willing to waste and just added it to the long, long, long, long list of stupid, sucky, idiotic crap that passes for software in the 21st Century. For about the 10,000th time this month, the answer is to just deal with it because there's no way to solve the non-stop onslaught of useless changes being made just so marketing departments can have new features to advertise. If software developers spent a hundredth as much time trying to figure out how to help us as they do taking over our computer screen real estate for advertising their crap, trying to manipulate us, and attempting to force us to do everything they way the developer prefers to do things, maybe we could get some work done without having to waste so much time on this type of crap. I will never get back the thousands of hours of my life that have been wasted trying to undo some ridiculous change that some idiot in a cubicle somewhere decided that I have to have so badly that there's no way to prevent it from taking over my desktop. Thanks for trying to help. The problem isn't with your willingness to help but I'm done anyway. I have no more of my life to waste on yet another piece of crap software that thinks it knows better than I do how I want to use my own computer. I mean, come on, man. All I want is a blank page when I click the new tab control but look how it is practically impossible to achieve even with so many smart people trying to do it. We were better off with monochrome monitors and text-based applications; we got a heck of a lot more work done.
John 0 solutions 37 answers

Helpful Reply

Have to say that I rather agree with Mark..all we want is a simple, unadorned clean page that doe not track and show usage!! WHY NOT!! Is it too simple for developers..we aren't all (nor do we want to be!) software experts! Come on Mozilla..tidy up and clean up..it might be a quicker programme too!!

Have to say that I rather agree with Mark..all we want is a simple, unadorned clean page that doe not track and show usage!! WHY NOT!! Is it too simple for developers..we aren't all (nor do we want to be!) software experts! Come on Mozilla..tidy up and clean up..it might be a quicker programme too!!