Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Firefox is already running, but is not responding..."

  • 15 replies
  • 138 have this problem
  • Last reply by oldgrayfox

more options

This only occurred after I upgraded to Firefox 25.0. I've already tried all the methods as described here:

Using these methods, it does work. However, after each restart, another parent.lock file is created and the profile folder becomes read-only again. How do I fix this permanently? Move to Chrome?

Chosen solution

Just to say I've had no problems at all with Firefox 26. It's now been 10 days since I downloaded and installed it and not one 'Firefox is already running, but is not responding' error.

Read this answer in context 👍 1

All Replies (15)

more options
more options

I have this problem, too, and it only began with Firefox 25. Firefox 24 didn't have this issue, neither did years worth of prior versions. The articles linked "fix" the issue with Safe Mode and no extensions but that's not an option. I tried a new profile and that didn't work. I tried disabling each extension, one by one, and that didn't fix it. I only had 3 extensions - Noscript, Adblock Plus and Fireshot which are all popular and work with 24. When I uninstall 25 and install 24, the issue doesn't appear. Upgrading to 25 through the update manager or standalone and the issue appears.

There's a few similar reports but Firefox has, so far, not confirmed this to be an issue. I suspect it is a bug. The only way to "fix" this is to force-close Firefox in the Task Manager, but then the issue will often repeat itself again upon the next time you want to close and reopen Firefox.

By the way, the parent.lock file is not the problem. Apparently that file now stays in new versions and is supposedly no longer deleted. Firefox has simply not updated their own articles.

Modified by Turbocpe

more options

Just an update.

So it seems Adblock Plus was the culprit. Also, installing Adblock Edge with more than 2 lists will cause the same error. But Adblock Edge with only 2 lists or less does not cause the error.

more options

Are you sure it's fixed for you? Mine is intermittent. I can sometimes sucessfully close and reopen Firefox several times in a row but often times it will give the 'open but unresponsive' error that requires a force kill in Task Manager. I'm using Adblock plus but disabling that extension, and the other two extensions one at a time, did not resolve my issue.

more options

Well, enabling only 1 addon at a time, it seems Adblock was the culprit. But, this article really helps:

more options

hi my name is alex is firefox not responding

more options

I downloaded Firefox 26.0 earlier this morning and, so far, everything is behaving perfectly. I haven't had a single 'Firefox is already running, but is not responding' error.

Fingers crossed!

more options

Chosen Solution

Just to say I've had no problems at all with Firefox 26. It's now been 10 days since I downloaded and installed it and not one 'Firefox is already running, but is not responding' error.

more options

Thanks for posting this! Hopefully it will solve my problem.

Modified by jhughey

more options

i have been able to DETECT the conditions that create this problem, at least in my scope of use. now i am running MFF 26.0 , but i also had this problem with previous versions. to save URL of site of my interest, i first highlight the URL text, then i place the cursor on the icon next, "drag & drop" that icon from the address window into my destination (desktop, or a folder), while pressing the CTRL key. this is a feature of all windows OS, and MFF complies with it. however, somehow the problem of "Firefox is running...." gets created. i hope this contribution will help MFF programmers to definitively eliminate this instance.

more options

I also have this issue with FF 26 every few days, but not every day. When it happens and I look in the task manger, FF uses a CPU over 40 with peeks up to 60. If I don't touch it, the process closes itself after a very long time, I never measured it but it's more then 5 minutes and sometimes after an hour it still uses a lot of CPU. It doesn't always happen and I haven't been able to figure out when this issue starts.

  • it most definitely happens after using FF for a long time.
  • it looks like it depends on the content of the websites I have visited.
  • maybe websites with flash content because when it happens there are also 2 flashplayerplugin processes running.
  • maybe after using facebook for a while. Usually, the FF process is around 0% after a page is fully loaded. But if I open facebook, the CPU goes up to 20-30 and just stays there even after the page is fully loaded for as long as that tab is active. It calms down when I keep FB open but activate another tab.
  • I have thousands of bookmarks. At first I thought it was a FF sync issue, but I have disabled that and it hasn't resolved the issue.

The plug-ins I have installed

  • Adobe Acrobat
  • Shockwave Flash
  • Garmin Communicator

And extensions

  • Babylon translation activation
  • Babylon spelling and proofreading (paid version, not the free spammy one that causes a lot of issues you read everywhere on the net)
  • Garmin Communicator
  • Office launcher
  • Xmarks (with auto sync disabled)

There are also a few plugins and extension disabled that do not have a delete option.

Modified by JPNL

more options

Been getting this since Firefox 29 Beta 1 (using Beta 8 as I type this). Rolling back to version 28 completely "fixes" the problem (and all versions before it), so it's looking more and more like it's a v. 29 issue of sorts. None of the "official" solutions work (as per ). I've made sure that the profile folder is not read-only, I've must have deleted the parent.lock file over 2 dozen times (not exaggerating), and decided to do a full clean install of Firefox when Beta 4 (29) was released. Nothing seems to work here and unless it's a plug-in, I don't know what else to try as the only thing that works is to manually terminate the process to be able to re-launch Firefox.

No other programs behave this way, and like I said, none of the previous versions do either. My system is clean, memory is top-tiered with 0% errors in Windows/third-party memory tests, haven't fiddled around with about:config. I haven't noticed any patterns either. I can close Firefox with 1 or 20 tabs, and it may open again or not, I might close it and open it right away or go have coffee and return (many minutes later), and it might work or it might not. I could be running other apps or not, and it may or may not relaunch - in other words, I can't see a pattern of when it might not open after closing it. I'm at a loss!

Modified by omnimodis

more options

I just started using firefox 29, first time user . Am having this problem also, is terribly annoying and have to restart my computer several times a day due to it. How can I get the version 28?

more options


I'm using 28 and this problem crops up at least a couple of times a day. Rather than restarting your computer each time, try opening your Task Manager, select 'Processes' and scroll down for your 'Firefox.exe' file. Click on it once to highlight it and then select 'End Process'. Close down the Task Manager windows and you should be able to go back into Firefox straight away. It works every time for me in Windows 7 and it's certainly quicker than re-booting each time ;-)

more options


thanks a lot, will certainly give that a try next go around and am using windows 7 also so this is a big help !