Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't open a local file because file handling removes colon from the file path.

  • 1 reply
  • 1 has this problem
  • 18 views
  • Last reply by zeroknight

more options

Hi, I have a link in my website that opens a file in another desktop program. The link looks like this: openwith://C:/path/to/file, but after update to the latest Firefox version (v122.0) the second colon from the link is for some reason removed, resulting in a path like this: openwith://C/path/to/file. This is a problem because the path it now tries to open doesn't exist. Is this a deliberate feature in the new Firefox version or is it a bug? If it is a bug will it be fixed? It still works fine in v121.0.

Hi, I have a link in my website that opens a file in another desktop program. The link looks like this: openwith://C:/path/to/file, but after update to the latest Firefox version (v122.0) the second colon from the link is for some reason removed, resulting in a path like this: openwith://C/path/to/file. This is a problem because the path it now tries to open doesn't exist. Is this a deliberate feature in the new Firefox version or is it a bug? If it is a bug will it be fixed? It still works fine in v121.0.

Chosen solution

Links with the format openwith://url need to be changed to openwith:url without the two forward slashes ("//") and Chrome will soon be the same (Bug 1876729).

You can revert this by changing network.url.useDefaultURI to false in about:config then restart the browser.

From the release notes:

The fallback URL parser for unknown schemes was changed to DefaultURI, this improves specification adherence and web compatibility.
Read this answer in context 👍 1

All Replies (1)

more options

Chosen Solution

Links with the format openwith://url need to be changed to openwith:url without the two forward slashes ("//") and Chrome will soon be the same (Bug 1876729).

You can revert this by changing network.url.useDefaultURI to false in about:config then restart the browser.

From the release notes:

The fallback URL parser for unknown schemes was changed to DefaultURI, this improves specification adherence and web compatibility.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.