Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Opening CNN site from Firefox

  • 5 replies
  • 1 has this problem
  • 87 views
  • Last reply by Ed Chang

more options

Update to Firefox (120.0.1) in Linux Mint blocks CNN - its the only site which appears to be blocked. I get a message telling me that configuration of the site is blocking CNN from loading, and goes on as follows.

"" We apologize, but your web browser is configured in such a way that it is preventing this site from implementing required components that protect your privacy and allow you to view and change your privacy settings. This functionality is required for privacy legislation in your region.

We recommend you use a different browser or disable the “EasyList Cookie” filter from your “Content Filtering” settings (found under “Settings” -> “Shields” in the Brave Browser). ""

Rather strange, since I'm using Firefox.

In general, I am thoroughly annoyed with the way the Internet experience is increasingly fouled up by various sites implementing "safety" aspects. It used to be fun, now its a crap experience. Firefox is getting bigger, slower, and infested with site 'improvements' which do absolutely nothing for me - Is it so hard to provide a simple, clean, straightforward browser without so many 'add-ons' that its grinding to a halt? Time was software was written for the users, now its clearly written to give software developers something to do. Can't you create a revolution in software and do something useful, instead of "clever"?

Update to Firefox (120.0.1) in Linux Mint blocks CNN - its the only site which appears to be blocked. I get a message telling me that configuration of the site is blocking CNN from loading, and goes on as follows. "" We apologize, but your web browser is configured in such a way that it is preventing this site from implementing required components that protect your privacy and allow you to view and change your privacy settings. This functionality is required for privacy legislation in your region. We recommend you use a different browser or disable the “EasyList Cookie” filter from your “Content Filtering” settings (found under “Settings” -> “Shields” in the Brave Browser). "" Rather strange, since I'm using Firefox. In general, I am thoroughly annoyed with the way the Internet experience is increasingly fouled up by various sites implementing "safety" aspects. It used to be fun, now its a crap experience. Firefox is getting bigger, slower, and infested with site 'improvements' which do absolutely nothing for me - Is it so hard to provide a simple, clean, straightforward browser without so many 'add-ons' that its grinding to a halt? Time was software was written for the users, now its clearly written to give software developers something to do. Can't you create a revolution in software and do something useful, instead of "clever"?
Attached screenshots

Chosen solution

uBlock Origin has the "EasyList – Cookie Notices" filter list in the Annoyances section.

Try disabling all your extensions from the about:addons page.

Read this answer in context 👍 0

All Replies (5)

more options

Does it still happen in Troubleshoot Mode?

Helpful?

more options

No - it can open the CNN site when Firefox is running in 'safe' mode. Before posting, I had already tried disabling all the add-ons I could find in case they were causing the problem. The previous version of Firefox (before routine upgrade) was exactly the same configuration, but was able to load the CNN site (as did all older versions of Firefox). It also appears to block 'any' site related to CNN. The message displayed (see previous screenshot) refers to "easylist cookie" filter, which I cannot find - maybe cause of problem? I note the error message is from CNN (not FIrefox) complaining about the blockage, but indicates it is a Firefox issue.

Helpful?

more options

Chosen Solution

uBlock Origin has the "EasyList – Cookie Notices" filter list in the Annoyances section.

Try disabling all your extensions from the about:addons page.

Helpful?

more options

Thanks, zeroknight. I disabled all the add-ons, then enabled them one by one, and tried to open CNN - eventually found out that "I don't care about cookies' caused the blocking. I tried to contact its developer, but the e-mail address given for him on the IDCAC site is apparently dead. The add-on is listed in the Mozilla Firefox add-ons - I have used it for a long time, to get rid of the nuisance cookie warning mandated by the EU, so I hope it can be fixed eventually.

Thanks again for the help - I learned something. Keith

Helpful?

more options

I also had this problem. I have the "I still don't care about cookies" Extension. I added www.cnn.com to the Options->whitelist and it solved that problem.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.