Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No Audio on firefox browser only

  • 4 replies
  • 2 have this problem
  • 875 views
  • Last reply by Radu A

more options

Audio on my PC works except on the firefox browser. The browser is not muted, I've checked the volume mixer, i've reinstalled firefox, but nothing seems to work. This just started occurring a couple days ago. When I restart the pc, i will get audio from firefox for a couple seconds then audio stops.

Audio on my PC works except on the firefox browser. The browser is not muted, I've checked the volume mixer, i've reinstalled firefox, but nothing seems to work. This just started occurring a couple days ago. When I restart the pc, i will get audio from firefox for a couple seconds then audio stops.
Attached screenshots

Chosen solution

Thanks for the replies. Nothing has helped so far. jonzn4SUSE, I have my audio setting set to DEFAULT. One thing that I noticed is on the Volume mixer tab, my icon for firefox is just a blue square, where yours is the actual icon, could this be a clue as to something wrong?

Read this answer in context 👍 0

All Replies (4)

more options

Hey there! It sounds like you're having a bit of trouble with audio on Firefox. Since you've already checked the basics like volume settings and even reinstalled Firefox, we can try a couple more things. First, make sure your Windows sound settings are okay – sometimes they can affect browser audio. Also, consider updating your audio drivers. If the issue persists, you might want to check if any recent extensions or add-ons are causing this. Sometimes they can play a role. And don't forget to clear your browser cache, it might help too. Also go to your settings and look at what the volume level is for FireFox. Give these steps a shot, and hopefully, your audio will be back to rocking on Firefox! If not, we're here to help more.

more options

For Firefox, you should click on the down arrow to see what the options are. see screenshot What is your sound setup? As you can see in my screenshot, I have a dock and speakers plugged into it.


Edition Windows 11 Pro Insider Preview Version 23H2 Installed on ‎29-‎Jul-‎23 OS build 25915.1000 Experience Windows Feature Experience Pack 1000.25915.1000.0

more options

Chosen Solution

Thanks for the replies. Nothing has helped so far. jonzn4SUSE, I have my audio setting set to DEFAULT. One thing that I noticed is on the Volume mixer tab, my icon for firefox is just a blue square, where yours is the actual icon, could this be a clue as to something wrong?

more options

I've had the same problem multiple times. This happens in Windows 11 when you are using external speakers and play an audio file while the Firefox browser is open. When you close the audio file and restart Firefox, sound remains muted although there is no indication of that in sound settings. The solution is: You have to MANUALLY change your advanced audio settings for Firefox from default to "speakers". Go to Settings - System - Sound - Advanced Sound Options - Mozilla Firefox - Speakers. Once you have done that, the browser plays sound again. If you choose advanced sound in settings again, the indication is once again "default".