Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Restore Previous Session

  • 1 reply
  • 1 has this problem
  • 29 views
  • Last reply by cor-el

more options

Why isn't the Restore Previous Session choice available on the Open Application Menu? Even if I click the checkbox under Tools/Settings/General/Startup: Open Previous Windows and Tabs (version 107/windows 11), I am presented with a tabula rasa screen on reopening my Firefox session. Your help/support says to go to the Open Application Menu/History and choose Restore Previous Session (located between Recently Closed Windows and Clear Recent History). However the Restore Previous Session is not listed. Not sure why Firefox can't get this right since you have had it right for the almost 20 years I have chosen it as my default browser.

Why isn't the Restore Previous Session choice available on the Open Application Menu? Even if I click the checkbox under Tools/Settings/General/Startup: Open Previous Windows and Tabs (version 107/windows 11), I am presented with a tabula rasa screen on reopening my Firefox session. Your help/support says to go to the Open Application Menu/History and choose Restore Previous Session (located between Recently Closed Windows and Clear Recent History). However the Restore Previous Session is not listed. Not sure why Firefox can't get this right since you have had it right for the almost 20 years I have chosen it as my default browser.

All Replies (1)

more options

If you select "Startup -> Open previous windows and tabs" then you already open the previous session and this means that "Restore Previous Session" isn't available. It is grayed in the History menu and not present (hidden) in the History panel in the "3-bar" Firefox menu button drop-down panel. When there is a session to restore then "Restore Previous Session" is present and enabled.

Make sure Firefox isn't set to run in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"

In case you use "Clear history when Firefox closes".

  • do not clear the "Browsing history"

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.