Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is configure to not delete cookies or history, but it still clears them

  • 5 replies
  • 1 has this problem
  • 8 views
  • Last reply by vda1

more options

I have Firefox 99 for Mac "Delete cookies and site data when Firefox is closed" is unchecked History is set to "Remember History" Enhanced Tracking Protection is set to "standard"

Yet every time I return to a site where I've checked "remember me" , I'll get prompted to login, and perhaps also get a security message "you've logged in from a new computer" in my email from the site.

Is there an easy way to verify that Firefox is storing cookies for a site. Maybe an option to right-click on a site's web page and view "cookies are stored for this site" in the context menu? I'm losing a lot of my productivity time logging back into sites that I just logged into earlier in the day.

I have Firefox 99 for Mac "Delete cookies and site data when Firefox is closed" is unchecked History is set to "Remember History" Enhanced Tracking Protection is set to "standard" Yet every time I return to a site where I've checked "remember me" , I'll get prompted to login, and perhaps also get a security message "you've logged in from a new computer" in my email from the site. Is there an easy way to verify that Firefox is storing cookies for a site. Maybe an option to right-click on a site's web page and view "cookies are stored for this site" in the context menu? I'm losing a lot of my productivity time logging back into sites that I just logged into earlier in the day.

All Replies (5)

more options

Screenshot of your settings?

Helpful?

more options

Firefox normally shows a special 'You have granted this website special permissions' icon at the at the left end of the location bar if you made changes to the permissions like allowing cookies.

See also "Tools -> Page Info -> Permissions".

Helpful?

more options

The simplest way to view cookies is Settings > Privacy & Security > Cookies and Site Data > Manage Data. You can also open the Inspector with ctl+shft+i and click on the Storage tab. If you are using custom settings for history, I suggest do NOT select Clear History when Firefox closes.

Helpful?

more options

I'm going to be away from the computer with the cookies issue for a fews days ( thanks, work!) but I'll provide screenshots of settings when I get back to it.

Helpful?

more options

Also check if there are any add-ons installed that will auto delete cookies/history.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.