Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Copy and paste into new tab search bar always "looses" the first word

  • 7 replies
  • 2 have this problem
  • 13 views
  • Last reply by verminhater

more options

If I copy and paste any two words or more into the search bar on the new tab it goes to google.co.uk as that is set but only searches for the phrase minus the first word. If I paste it into the address bar everything is ok. If I do the same with a one word term the search bar does nothing having "lost" that word and the address bar works fine.

Chosen solution

Did you turn off the feature to flip your input up to the address bar, or does that make any difference? This is the preference for that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator.]


(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true (move query to address bar) to false (keep query in in-page search bar)

Read this answer in context 👍 0

All Replies (7)

more options

Workaround:

Click on the right top corner on the settings gear inside the browser page. Deactivate sponsored links. (I added a couple of files to results also, but I don't see it doing any good for the problem)

Close.

Problem is solved.

I would say Amazon link is doing something nasty with search words.

Helpful?

more options

I don't see how that is a workaround for this. It still removes the first word when anything copied is pasted into the search bar yet is still fine when pasted into the address bar. No behaviour has been changed.

Helpful?

more options

It also doesn't matter what search engine I set as the default, it still looses the first word.

Helpful?

more options

Also worth mentioning that starting in safe mode with add-ons disabled gives the same behaviour.

Helpful?

more options

Also my laptop does the same as my desktop.

Helpful?

more options

Chosen Solution

Did you turn off the feature to flip your input up to the address bar, or does that make any difference? This is the preference for that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator.]


(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true (move query to address bar) to false (keep query in in-page search bar)

Modified by Chris Ilias

Helpful?

more options

Thank-you. That has solved the issue.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.