Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Search.....

  • 70 replies
  • 32 have this problem
  • 1847 views
  • Last reply by Chris Ilias

more options

One of your recent updates has all searches forced to the address bar..... I use the Google search box on my homepage and from the first letter its moved to the address bar... Go back to the Google box on the homepage.... You've made it useless....

Chosen solution

There is an option to turn that off at the moment, but I don't know whether it is a permanent option:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

Read this answer in context 👍 46

All Replies (20)

more options

Standard8 said

Hi, if you're using the Google search box on the default Firefox home page, that is virtually identical to searching from the address bar. The address bar will give you search suggestions (if they are turned on), and it will also give you other suggestions from your Firefox history, open tabs and other items that match your query. Via the buttons at the bottom of the address bar pop-up you can limit to a single site. You can also limit what the address bar shows you. If that doesn't help, please can you explain why searching from the address bar is different or not suitable for your needs?

Thank you. I also unchecked "Search engines" from address bar suggestions.

more options

I can't believe Mozilla made a muck of the search function. Now it looks and works like Safari -- wonderful ... good job.

I'd like to see a v89 feature update which allows user to configure new tabs to be same as their homepage, or any other URL, such as google, -- or if using the Firefox homepage, make it possible to turn off the search suggestions.

?? Is there a way to roll back to v88 for now?

more options

prjpicard said

I'd like to see a v89 feature update which allows user to configure new tabs to be same as their homepage, or any other URL, such as google

You can use this extension to change your new tab page to a new option:

https://addons.mozilla.org/firefox/addon/new-tab-override/

or if using the Firefox homepage, make it possible to turn off the search suggestions.

You can turn off search suggestions in the settings. See: Search suggestions in Firefox.

more options

Your solution does not work by changing it to FALSE

more options

I agree defaulting to address bar to search is total garbage ... why did you do this .... i followed some of the fixes and couldn't search at all or enter an address bar .... the people who post this stuff have no clue what is being asked and provide solutions that don't work

FIREFOX .... RESTORE DEFAULT SEARCH TO SEARCH BOX OR MAKE IT EASY TO STOP THIS INSTEAD OF OF ALL THIS TYPE IN CONFIG NONSENE, THEN TYPE THIS, THEN DO THAT, THEN THIS

I'M JUST GOING TO USE GOOGLE CHROME FROM NOW ON .... FIREFOX IS NO USE TO ME FOR THIS

WHO WAS THE GENIUS WHO CAME UP WITH THIS

more options

hartc034 said

Your solution does not work by changing it to FALSE

Hi hartc034, this change is still working for me:

You could try doing a regular exit and restart of Firefox to see whether that helps your Firefox get the message.

more options

I have 3 browsers. I use Firefox as my main browser. This is the first version where search jumps to the address bar. Opera doesn't have this setting or if it does at least it's not set by default.

I have Microsoft Edge which I hardly use and I just checked so when trying to type in the Bing search box, it jumps to the address bar. Okay. Fine.

BUT you can easily go into Edge settings and turn it off so it now types into the Bing search box again.

Why do I have to start typing into Firefox "about: config" to fix it from there? It should be in search settings.

And why don't I like it? Because like someone else said it makes sense that the address bar is for addresses and the search box is for searches. AND maybe because I'm just old and cranky.

It's not the first little changes to Firefox in the last several updates that just seem more limiting or inconvenient. Like the "image info" when right clicking on an image.

EDIT - Correction "about:config" without a space.

Modified by BarbaraML

more options

Hi BarbaraML, when you type about:config don't type a space after the colon. Otherwise, you'll get puzzling search results instead of the built-in page.

more options

hartc034 said

Your solution does not work by changing it to FALSE

It worked for me, other than if you have very long search text, then it becomes a jumble at the end of the Search Bar

more options

Does anyone from Mozilla Firefox look at any of our posts? Ever? Whilst I have used the temporary fix as posted by jscher2000, this is only a partial fix, due to the jumbled mess that ensues if one has very long text in the Search Bar. This still needs a fix by Firefox. The choice to use this Search Bar on one's Home Page is noted in Settings, but does not work, without jscher2000's temporary fix.

Mozilla - PLEASE FIX THIS, SO WE HAVE THE FULL OPTIONS AVAILABLE. URGENT PLEASE. THANKS!

more options

TP said

Does anyone from Mozilla Firefox look at any of our posts? Ever?

Some of the threads, yes. Probably not all of them.

Whilst I have used the temporary fix as posted by jscher2000, this is only a partial fix, due to the jumbled mess that ensues if one has very long text in the Search Bar.

Do you mean this, where long text appears on top of the submit button instead of staying to the left of it (or going behind it):

Probably someone has filed a bug for that by now but, if not, you can submit one here:

https://bugzilla.mozilla.org/

more options

Do you mean this, where long text appears on top of the submit button instead of staying to the left of it (or going behind it):

Probably someone has filed a bug for that by now but, if not, you can submit one here:

https://bugzilla.mozilla.org/ </blockquote>

Hi jscher.... yes, that is what I mean.... it should wrap around onto a second line just like this box that I am typing in at present.... this has all come about thanks to the 89.0 update! I will report it on the bugzilla link you have posted above... thanks for your help anyway, as I think I would go totally nuts if I couldnt use the middle Search Box on the Home Page.... take care!  :-)

more options

Trying out the "fix"... A little put off by the warning. The newest update made the search bar in the middle of the page redundant since I cannot make searches in it? It literally has no purpose in this scenario.

I don't like the text jumping to a new box, I don't like getting address suggestions as well as word suggestions when searching. I do like having a word/phrase search bar and an address bar that are separate as they serve two similar but different purposes in the search process... Bottom line, seemingly, is that the home page looked great and worked great before the alleged update and now, not so much.

This is the way microsoft killed itself (slow death still happening) Windows used to be great but they upgraded it into oblivion. I was very happy with Firefox version 88, now i am annoyed and wondering what next. No, please, don't feel sorry for me, i am just saying, change is not always a good thing. knowing what to change and what to leave alone cannot be easy and there are a bunch of programmers out there who need to do stuff, but at some point the masterpiece is a work of art and one more brush stroke will make it less than it was....

Thanks to all you hard working volunteers who keep this huge pile of code plodding along!

more options

Each browser is customize in its own way. Opera, Chrome, Edge - "Settings", only. Firefox "Settings" and "about: config". That's why everyone likes Firefox. There is no problem.

But fix "browser.newtabpage.activity-stream.improve search.hand off To Awesome bar = false" is invalid. This does not correct the search box "as a rule". After the fix, there are two problems: the button and the cursor.

1.Long text on top of the submit button . 2.The cursor begins to move freely at the area of the sites, on their own.

That are the problems.

more options

zagrugai said

2.The cursor begins to move freely at the area of the sites, on their own.

You see the vertical (insertion) bar moving around in pages if you press the arrow keys or Page Up / Page Down keys? That sounds like "caret browsing." On the Settings/Options/Preferences page, you can search for cursor in the tiny search box and then make sure this preference is turned off (unchecked):

more options

...you can search for cursor in the tiny search box... No need to search for anything in the tiny search box. These are the open default browser settings. The "General" tab. I have the cursor working after the fix "browser.newtabpage.activity-stream.improve search.hand off To Awesome bar = false" . When the checkbox is empty.

more options

you can search for cursor in the tiny search box No need to search for anything in the tiny search box. These are the open default browser settings. The "General" tab. I have the cursor working after the fix "browser.newtabpage.activity-stream.improve search.hand off To Awesome bar = false" . When the checkbox is empty.

more options

By the way "Always use the cursor keys to navigate within pages" the box is empty by default. But you can also use about:config accessibility.browsewithcaret_shortcut.enabled > false/true accessibility.browsewithcaret > false/true

more options

zagrugai said

By the way "Always use the cursor keys to navigate within pages" the box is empty by default. But you can also use about:config accessibility.browsewithcaret_shortcut.enabled > false/true accessibility.browsewithcaret > false/true

If you set the shortcut one to false, then you can't accidentally turn on caret browsing by pressing the F7 key. Good for people whose fingers tend to fly around quickly.

more options

As I said in my version of the same complaint Microsoft knows better than you what you are thinking and what you intend to do. No they do not. I constantly fight MS software to do what I need.

In my car if I press the accelerator pedal, I don't expect the radio to change stations.

Don't be like the assholes at Microsoft. Put my search back on the screen/page I start typing on. (HINT: If I wanted to type in the address bar - I would type in the address bar)

  1. 1
  2. 2
  3. 3
  4. 4