Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

OMG WHY DO YOU MAKE IT SO HARD TO FIND THE LINK TO "ASK A QUESTION"?

more options

Having wasted 20 mins on this problem and getting nowhere with this "help:"

=

"the-edmeister

   Moderator

3/2/20, 2:07 PM Right where you posted that question / inquiry. Users are expected to first attempt to find an answer via the Help Topics

The entry point is here: https://support.mozilla.org/en-US/products/firefox after clicking on Help Articles > Firefox which sends you to. Frequent Help Topics. Select something there to be able to access the Knowledge Base to find an answer yourself.

Then if you can't find a suitable answer you will have the opportunity to Ask a question."

==

NOPE. SEE IMAGES.

I had to google it. And for the record the advice above was useless even after following the ---> "Frequent Help Topics. Select something there to be able to access the Knowledge Base to find an answer yourself." advice.

GEEEEZ NO I can waste more of my time figuring out why YouTYube Comment replies don't load, Firefox doesn't open new pages in tabs (despite being set to) and why this browser won't even quit.?

I used to use Firefox for a decade plus but stopped because it became a buggy useless piece fo software.

Attached screenshots

All Replies (2)

more options

I agree with the title. I ask the same question many months ago.  ;-))

Modified by jonzn4SUSE

Helpful?

more options

The named changed to "Get Help" -- it's at the top of each page -- and after you click that, you click "Ask the Community".

Seems these are your questions:

bard2 said

[1] why YouTYube Comment replies don't load, [2] Firefox doesn't open new pages in tabs (despite being set to) and [3] why this browser won't even quit.?

For #1, it could be a blocker. Tips on that below.

For #2, scripts links may be treated as exceptions. Usually you'll get the limited toolbar in that case. If you have an issue with those kinds of links, see solution below.

For #3, do you get a crash during shutdown? What's going on?


If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Tracking Protection feature, and extensions that counter ads and tracking, may break websites that embed third party content (meaning, from a secondary server).

(A) The shield icon toward the left end of the address bar usually turns a bit purplish when content is blocked. Click the icon to learn more or make an exception. See: Enhanced Tracking Protection in Firefox for desktop.

(B) Extensions such as Adblock Plus, Blur, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix usually provide a toolbar button to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you sometimes need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe/Troubleshoot Mode: In this mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any improvement?


To force limited-feature scripted popups to open in a new tab instead:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste neww and pause while the list is filtered

Normally you'll see four rows starting with browser.link.open_newwindow:

(3) Review/Edit the preference values as follows (double-click the current value to open an editing field, and then when you're done, press Enter or click the blue checkmark to save the change):

(A) browser.link.open_newwindow - for links in Firefox tabs

This is the one that has a checkbox on the Preferences page and determines whether targeted links are allowed to open in a new window or are diverted to a new tab instead; there's no effect on untargeted links:

  • 3 = divert new window to a new tab (default) <= Make sure this is still set
  • 2 = allow link to open a new window
  • 1 = force new window into same tab

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

By default, if a page sets width, height, or toolbars for a popup, Firefox will open it in a "dialog-style" window. To force those into a tab as well, you can change this preference to 0:

  • 0 = apply the setting under (A) to ALL new windows <= set this to tame scripted windows
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

This preference governs those external links that open in Firefox (not directly relevant to your question):

  • -1 = apply the setting under (A) to external links (default) <= Usually best, or try setting to 3
  • 3 = open external links in a new tab in the last active window
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page

To return to normal if things go haywire, there's an arrow-like reset button at the right end of each of those rows if it has a non-default value.

Working any better?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.