Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF shows: Updates deactivated by system administrator (Just now FF84.01)

more options

Hello, since some time Firefox does't download updates. On HELP/ABOUT there is the installed version and below Updates Deactivated by your system administrator ... . I don't have a system administratot, it's a netbook. Sometimes before FF would download updates for installation. Now now more. Updates are only available by dowloading and reinstallations. After reading some help articles, I tried to get rid of registry entries, no success. I tried to cleanly uninstall FF, clearing the registry and reinstalling. The problem remains. Mind you, this has been created by FF itself. Any ideas how to get rid of this nuisance? Many thanks for a reply.

Andy

Chosen solution

You can inspect the Mozilla and Firefox keys with the Windows Registry Editor in HKEY_LOCAL_MACHINE and in HKEY_CURRENT_USER with the Windows Registry Editor to see whether GPO policy rules are active.

  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox\

Note that the mere presence of the "Mozilla\Firefox\" key is sufficient to make Firefox display this notification, so if you have the Firefox key then remove it and only leave the Mozilla key or remove this key as well if it is empty.

  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox\ =>
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\
Read this answer in context 👍 2

All Replies (4)

more options

Found this on the interwebs... see if it helps.

Opening Mozilla Firefox, the going to Help, and About Firefox yields the following error: "Updates Disabled By Your System Administrator"

Verified Solution 8-8-2015:

Found Mozilla.cfg file located in C:\Program Files\Mozilla Firefox

Editing Mozilla.cfg with notepad shows: // lockPref("app.update.auto", false); lockPref("app.update.enabled", false);


Changed this to: // lockPref("app.update.auto", true); lockPref("app.update.enabled", true);

more options

Also, could you open the about:policies page and see whether there are any update-related policies active?

One way those might get applied is via the Registry, and the other way is a policies.json file. More info on that file and where it could be found in this article: Customizing Firefox Using policies.json.

more options

Chosen Solution

You can inspect the Mozilla and Firefox keys with the Windows Registry Editor in HKEY_LOCAL_MACHINE and in HKEY_CURRENT_USER with the Windows Registry Editor to see whether GPO policy rules are active.

  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox\

Note that the mere presence of the "Mozilla\Firefox\" key is sufficient to make Firefox display this notification, so if you have the Firefox key then remove it and only leave the Mozilla key or remove this key as well if it is empty.

  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox\ =>
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\
more options

Thank you very much to all, this was helpful. Anyway I saved the cure, as I am not sure whether this will show up again. Thanks again, Andy