Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

new FF 82.0.2 not working with Netflix

  • 2 replies
  • 1 has this problem
  • Last reply by jacomejm

more options

Today (oct30) Netflix has stopped working on FF. I'm running v.82.0.2 which just updated maybe yesterday or the day before. It was working yesterday. I'm getting an error "This title is not available to watch instantly - Error code F7121-1331" and won't load any title. I can watch on MS Edge alright. I've tried FF in Safe Mode with no improvement. Any ideas? Thanks.

All Replies (2)

more options

At least you can watch on Edge for now until someone figures it out.

When I search about this error, it seems it could be related to the connection. Do you use any VPN software that might be affecting how Firefox connects to Netflix?

Good idea to try Firefox's Safe Mode. When you have a problem with one particular site, another good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?


more options

Hi. Thanks for your reply. Tried both clearing cache and removing site's cookies, but problem continued.

So I've backed up all my FF data, uninstalled it, deleted all FF folders, and the reinstalled the earlier version 82.0.1. Also did a Refresh.

Netflix now seems to be working. I'll hold off on allowing it to update for a while.

Thanks again.


Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.