If you receive "An Error Occurred" message while posting on our platform, please bear with us as we are trying to fix this issue. Alternatively, you can reach out to @FirefoxSupport on Twitter/X.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I disable the mouseover to reveal the address/toolbar while in fullscreen?

  • 2 replies
  • 1 has this problem
  • 819 views
  • Last reply by akibby

more options

Is there a way to stop the address bar from being revealed when the mouse reaches the top of the screen while in fullscreen mode? I find this feature to be more of an annoyance than actually helpful as 90% of the time I trigger it on accident. It is exceedingly annoying when I trigger this while using Roll20 as it causes the camera to pan to the top left corner of the map I am on (see imgur link for example, gif was too large for upload).

https://imgur.com/A2G5x7l

I already know that you can right click the address bar while in fullscreen and select "Hide Toolbars" which will prevent it from retracting, but this is not a good solution because the toolbar uses more screen real estate than my windows taskbar does. Any additional help with my issue is greatly appreciated.

Is there a way to stop the address bar from being revealed when the mouse reaches the top of the screen while in fullscreen mode? I find this feature to be more of an annoyance than actually helpful as 90% of the time I trigger it on accident. It is exceedingly annoying when I trigger this while using Roll20 as it causes the camera to pan to the top left corner of the map I am on (see imgur link for example, gif was too large for upload). https://imgur.com/A2G5x7l I already know that you can right click the address bar while in fullscreen and select "Hide Toolbars" which will prevent it from retracting, but this is not a good solution because the toolbar uses more screen real estate than my windows taskbar does. Any additional help with my issue is greatly appreciated.

Chosen solution

See this thread about how to use userChrome.css to hide the Full Screen toggler.

  • [/questions/1200755] How do I make the toolbar not show up in full screen even when I move the cursor upwards?

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#fullscr-toggler { display:none!important; }
Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

See this thread about how to use userChrome.css to hide the Full Screen toggler.

  • [/questions/1200755] How do I make the toolbar not show up in full screen even when I move the cursor upwards?

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#fullscr-toggler { display:none!important; }
more options

Thanks so much for that! I was able to fix it after making my userChrome.css file and adding that text!