Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New version does not work

  • 10 replies
  • 4 have this problem
  • 273 views
  • Last reply by philipp

more options

The newest version for Windows 10 was just forced installed. Now it is terrible. Trys to open home page and dies. Comes back with Firefox not responding. After a while, it finally loads the home page. Your new version is going backwards in time. It is terrible. And I rely on Firefox for my internet connection and activity. I did your refresh and reinstall. Still garbage. Can I go back to the prior version? Your new version is horrible and I made no changes to any settings. Your force install happened and now it crawls to open up. HELPPPPPPPPPPPPPPPPPPPPPP Please

Chosen solution

I added FIREFOX.EXE to a trend exception list and seems to have corrected the issue. Thanks for your help.

Read this answer in context 👍 0

All Replies (10)

more options

hi, do you happen to have twitch on your homepage as one of the tiles in the "top sites"?

more options

Hi Philipp, thanks very much for your reply. Nope, do not. have not changed any settings. I was on V56 and then the auto update forced down v57 and that is when everything turned terrible. At times, just a little better, but response is bad. Even when I do get it open (default page of Yahoo as in the past), poor and if I open a new tab after Firefox is finally up, takes a while. Something got hosed. I did a complete uninstall and reinstall. Did not help. Thanks for your help

more options

Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

Reinstall with Current Release Firefox 57.0 with a Full Version Installer https://www.mozilla.org/firefox/all/

Please let us know if this solved your issue or if need further assistance.

more options

I performed all steps listed and did a full install. Still terrible. I was watching Task Manager when I started up Firefox. I saw one firefox job start, then another and another and another. Finally, there were 5 active Firefox jobs. Sounds like it got sick and tried to restart and restart and restart. So, maybe that is what is going on that it resubmits itself for some reason instead of starting, causing conflict? Just a guess. Thanks for your help. But, again, still very poor response. Just checked with Firefox up, and there are 5 tasks active named Firefox. do not remember that prior to V.57.

more options

could you enter about:crashes into the location bar and see if you have any recently submitted crash report ids showing up there? if so copy the latest few report ids from there starting with bp- & paste them here into a forum reply. this might give a clue if some third-party programs are hooking into your firefox...

more options

Here is the ID for the only submitted report: bp-24c29132-9956-443f-b48b-aa5b10171118. There is one unsubmitted from today and several unsubmitted from yesterday. Thanks much

more options

thanks, mainly trend micro is leaving its fingerprints there ("user mode hook"). please try to play around with its program settings to see if this can make any difference

they have also some documentation about troubleshooting problems with this particular hook, but that seems to be geared towards enterprise users: https://success.trendmicro.com/solution/1116063-isolating-the-problem-for-the-user-mode-hooking-umh-module-in-officescan-osce

more options

Thanks. I have not made any changes to Trend. What must be happening is the new version now does not play well with Trend. As mentioned, my environment is stable and nothing really has changed since before the update thru after. Yet, V.57 does not work very well. I will check out the link and also shut off Trend once to see if Firefox fires up faster. Thanks for your help

more options

Chosen Solution

I added FIREFOX.EXE to a trend exception list and seems to have corrected the issue. Thanks for your help.

more options

great, thanks for following up with the solution you've found!