Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

IDM add-ons integration fail on firefox 47.0..how to fix

  • 1 reply
  • 1 has this problem
  • 9 views
  • Last reply by dizaster

more options

The version of firefox 47.0 show IDM integration is incompatable..

All Replies (1)

more options

I believe you need to update you IDM, i have same as you and its work, my IDM is 6.25. I think up to 6.23 ill work fine, not sure. But I'm sure last version will work.