Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes since updated to Window 10

  • 2 replies
  • 14 have this problem
  • 4642 views
  • Last reply by Jun_M

more options

Since I updated to window 10, the firefox crashes whenever I close a firefox browser. Please kindly refer to the attached image, which is the crash report notification.

I am using the up to date firefox (40.0.3) and there is no problem in chrome.

Here are a few crash reports:

6cadc88c-8b3e-4a9a-813a-769fff9d83bf 8/31/2015 10:22 PM bp-60d04e2a-721f-4166-8652-b47752150831 8/31/2015 10:22 PM bp-e701196d-ed68-4dc6-8ca8-4e7af2150831 8/31/2015 8:36 PM bp-21eb4aec-6238-478e-8ed6-15c632150829 8/30/2015 2:18 AM bp-bf0734ad-5446-4074-b274-8b43c2150829 8/29/2015 11:20 PM bp-658198d6-6302-4fde-b05b-b05b92150829 8/29/2015 7:17 PM bp-46617a38-3969-413b-b848-fe5b62150828 8/28/2015 11:12 PM bp-8174bfeb-c0aa-4ab1-97af-63aee2150827 8/28/2015 1:05 AM bp-52be91e6-27ac-40f0-b62b-6a9c92150825 8/26/2015 12:43 AM bp-9bdd19e8-9451-4d06-af37-fc35d2150824

Thank you very much!

Chosen solution

hi Jun_M, unfortunately this is a (still unresolved) issue with nivida graphics cards on windows 10 - for the moment please try to disable hardware acceleration in the firefox menu ≡ > options > advanced > general which should make those crashes stop (that setting will take a restart of the browser to take effect).

Read this answer in context 👍 6

All Replies (2)

more options

Chosen Solution

hi Jun_M, unfortunately this is a (still unresolved) issue with nivida graphics cards on windows 10 - for the moment please try to disable hardware acceleration in the firefox menu ≡ > options > advanced > general which should make those crashes stop (that setting will take a restart of the browser to take effect).

more options

Thanks a lot, Philipp. It does solve my problem! Thanks for saving my browser before my semester starts :D!