X
Tap here to go to the mobile version of the site.

Support Forum

Suddenly Firefox has stopped working, whether I type the url or hit a bookmark. Why? This is very frustrating

Posted

hi about 2 days ago ff stopped working. i type an address into the usual window like i've done a million times, hit enter, and nothing happens. i click on a bookmark, the url shows up in the address window, but nothing happens. there are maybe 3 bookmarks that still work, and all the rest are duds. auto-complete still works, but firefox refuses to take to the address. i get a lot of "flash crashes" (thanks, adobe) so i recently updated flash, and that started the problem. this is why i distrust updates. (for the record, i keep current with firefox updates, even though it is still bloatware that uses 2 GB just to run 3 windows. anyway, any help you could offer would be most... helpful! (not sure why my exclamation points are printing as open-brackets, but hey, whatever, that's the internet) thanks, tim

hi about 2 days ago ff stopped working. i type an address into the usual window like i've done a million times, hit enter, and nothing happens. i click on a bookmark, the url shows up in the address window, but nothing happens. there are maybe 3 bookmarks that still work, and all the rest are duds. auto-complete still works, but firefox refuses to take to the address. i get a lot of "flash crashes" (thanks, adobe) so i recently updated flash, and that started the problem. this is why i distrust updates. (for the record, i keep current with firefox updates, even though it is still bloatware that uses 2 GB just to run 3 windows. anyway, any help you could offer would be most... helpful! (not sure why my exclamation points are printing as open-brackets, but hey, whatever, that's the internet) thanks, tim

Modified by cor-el

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.12
  • iTunes Detector Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.20125.0
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • NPWLPG

Application

  • Firefox 33.1.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
  • Support URL: https://support.mozilla.org/1/firefox/33.1.1/WINNT/en-US/

Extensions

  • Avira SafeSearch 1.1.0 (safesearch@avira.com)
  • Avira SearchFree Toolbar plus Web Protection 51.6 (toolbar_AVIRA-V7@apn.ask.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Avira Browser Safety 1.4.2 (abs@avira.com) (Inactive)
  • Free Download Manager plugin 1.5.7.6 (fdm_ffext@freedownloadmanager.org) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Mobile Intel(R) 4 Series Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2a42
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'8.1500.1000.2202']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 9-2-2009
  • driverDate2:
  • driverVersion: 8.15.10.1892
  • driverVersion2:
  • info: {u'AzureContentBackend': u'cairo', u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Mobile Intel(R) 4 Series Express Chipset Family Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 2
  • browser.places.smartBookmarksVersion: 7
  • browser.privatebrowsing.autostart: True
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140923175406
  • browser.startup.homepage: http://www.google.com
  • browser.startup.homepage_override.buildID: 20141113143407
  • browser.startup.homepage_override.mstone: 33.1.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 33.1.1
  • font.internaluseonly.changed: True
  • general.autoScroll: False
  • media.gmp-gmpopenh264.lastUpdate: 1414701419
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1417470590
  • network.cookie.cookieBehavior: 1
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1417453806
  • places.history.expiration.transient_current_max_pages: 78696
  • places.history.expiration.transient_optimal_database_size: 125912350
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1414887905

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Question owner

worth a shot, cor-el, and thanks. (great username)

i'll let you know what happens.   happy new year to you all!
worth a shot, cor-el, and thanks. (great username) i'll let you know what happens. happy new year to you all!
FredMcD
  • Top 10 Contributor
4267 solutions 59838 answers

Taking a Screen shot; Windows > Start > search box > Snip. Select Snipping Tool.

Save the picture(s) to your desktop. Now look at the Reply box below. Press the button under it that says Browse. Now select the screen shot(s) from the desktop and load them one at a time.

Taking a Screen shot; '''Windows > Start >''''' search box '''''> Snip.''' Select '''Snipping Tool.''' Save the picture(s) to your desktop. Now look at the '''Reply''' box below. Press the button under it that says '''Browse.''' Now select the screen shot(s) from the desktop and load them one at a time.

Question owner

Damn, it's been over a week and I haven't done anything since your last good suggestion on the 31st. I'll give it a shot today. It's just so seductive to carry on in Safe Mode as opposed to starting and restarting and reopening all the windows that I need for my usual activities. But I'll get it done and let u know how/if it works.

Damn, it's been over a week and I haven't done anything since your last good suggestion on the 31st. I'll give it a shot today. It's just so seductive to carry on in Safe Mode as opposed to starting and restarting and reopening all the windows that I need for my usual activities. But I'll get it done and let u know how/if it works.

Question owner

BTW, I notice in Safe Mode, FF never uses more than 500K, but in normal mode, its draw grows dizzyingly fast, to where after 3 days, running 2 or 3 tabs uses 2Megs.

Safe Mode is not a panacea, of course: my PC's perfomance still stinks, with lots of latency and glitchy youtubes, but at least it works well enough for me to get stuff done.

Now my PC is generating little Emachines popups asking me to download the latest version of Flash. Doing so made nothing but trouble last time, why in hell would I trust it now?!?

BTW, I notice in Safe Mode, FF never uses more than 500K, but in normal mode, its draw grows dizzyingly fast, to where after 3 days, running 2 or 3 tabs uses 2Megs. Safe Mode is not a panacea, of course: my PC's perfomance still stinks, with lots of latency and glitchy youtubes, but at least it works well enough for me to get stuff done. Now my PC is generating little Emachines popups asking me to download the latest version of Flash. Doing so made nothing but trouble last time, why in hell would I trust it now?!?

Modified by TIMSPORES

FredMcD
  • Top 10 Contributor
4267 solutions 59838 answers

From your description, it could be an issue with an add-on.

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective

From your description, it could be an issue with an add-on. Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac:<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Disable a few add-ons, then '''Restart Firefox.''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective

Question owner

Thanks, Fred. I think I tried that on 12/31 and this is what I found then: "SYNOPSIS: FF will only work in Safe mode. If I try to run it in normal mode, even with all the add-ons disabled, FF will not work. I can type any address in the window and it just sits there. But when I re-start FF in safe mode, it all works fine... until the next Flash crash. " But I have nothing to lose by trying it again.

Thanks, Fred. I think I tried that on 12/31 and this is what I found then: "SYNOPSIS: FF will only work in Safe mode. If I try to run it in normal mode, even with all the add-ons disabled, FF will not work. I can type any address in the window and it just sits there. But when I re-start FF in safe mode, it all works fine... until the next Flash crash. " But I have nothing to lose by trying it again.
FredMcD
  • Top 10 Contributor
4267 solutions 59838 answers

While in the Add-ons Manager, go to the Plugin section, and set everything to Ask To Activate

While in the Add-ons Manager, go to the Plugin section, and set everything to '''Ask To Activate'''
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

Hi TIMSPORES, Firefox's Safe Mode varies from normal mode in several respects, including:

  • Extensions are disabled
  • Hardware acceleration is disabled
  • JavaScript compilers are disabled

If you want to see how Firefox works with a minimum set of extensions installed, you can try this test (mentioned before, but I can't tell whether you tried it):

Create a new Firefox profile

A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should come with completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager using Start > search box (or Run):

firefox.exe -P

Don't delete anything here.

Any time you want to switch profiles, exit Firefox and return to this dialog.

Click the Create Profile button, assign a name like Jan2015, and ignore the option to change the folder location. Then start Firefox in the new profile you created.

Does Firefox run normally in the new profile?

If so, it could be due to one of the extensions that does not exist in the new profile. If not, it's probably one of the other factors.

When returning to the Profile Manager, you might be tempted to use the Delete Profile button on Jan2015. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.

Hi TIMSPORES, Firefox's Safe Mode varies from normal mode in several respects, including: * Extensions are disabled * Hardware acceleration is disabled * JavaScript compilers are disabled If you want to see how Firefox works with a minimum set of extensions installed, you can try this test (mentioned before, but I can't tell whether you tried it): '''Create a new Firefox profile''' A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should come with completely fresh settings databases and a fresh cache folder. Exit Firefox and start up in the Profile Manager using Start > search box (or Run): firefox.exe -P ''Don't delete anything here.'' Any time you want to switch profiles, exit Firefox and return to this dialog. Click the Create Profile button, assign a name like Jan2015, and ignore the option to change the folder location. Then start Firefox in the new profile you created. Does Firefox run normally in the new profile? If so, it could be due to one of the extensions that does not exist in the new profile. If not, it's probably one of the other factors. When returning to the Profile Manager, you might be tempted to use the Delete Profile button on Jan2015. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.

Question owner

OK, Jscher, I am using FF in the way you described, and it all seems to work, although I miss my bookmarks. :)

Amazing how much better youtube runs  :-O

OK, Jscher, I am using FF in the way you described, and it all seems to work, although I miss my bookmarks. :) Amazing how much better youtube runs :-O

Modified by TIMSPORES

Question owner

So, what do I do now?

Working MUCH better now in the new mode you suggested, but CPU Usage is still spiking to 100%

So, what do I do now? Working MUCH better now in the new mode you suggested, but CPU Usage is still spiking to 100%

Modified by TIMSPORES

jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

You can manually migrate bits and pieces of the old settings files to the new settings folder, or alternately you can return to your old profile and try a Reset.

The CPU spiking is a concern. Does that seem to correlate with any particular kind of content?

You can manually migrate bits and pieces of the old settings files to the new settings folder, or alternately you can return to your old profile and try a Reset. * [[Recovering important data from an old profile]] * [[Reset Firefox – easily fix most problems]] The CPU spiking is a concern. Does that seem to correlate with any particular kind of content?
FredMcD
  • Top 10 Contributor
4267 solutions 59838 answers

As you move the Add-ons, only move a few at a time. If the issue returns . . . . . Do Not move any settings files. It might be where the problem is.

As you move the Add-ons, only move a few at a time. If the issue returns''' . . . . .''' '''Do Not''' move any settings files. It might be where the problem is.

Question owner

Thanks. regarding the CPU, it is worse during youtubes but it will often do it when little seems to be happening, and that mystifies me. Zero to 100%, then stay spiked at 100% for several seconds, then plunge back down to zero, maybe 3%, then maybe some zigzag spikes... right now it's mostly quiet but with some BIG transients that don't seem to correspond with anything.

Thanks. regarding the CPU, it is worse during youtubes but it will often do it when little seems to be happening, and that mystifies me. Zero to 100%, then stay spiked at 100% for several seconds, then plunge back down to zero, maybe 3%, then maybe some zigzag spikes... right now it's mostly quiet but with some BIG transients that don't seem to correspond with anything.

Modified by TIMSPORES

FredMcD
  • Top 10 Contributor
4267 solutions 59838 answers

Install this add-on. Then load a video page. Does the problem still happen? Then start the video. What happens?

Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

Install this add-on. Then load a video page. Does the problem still happen? Then start the video. What happens? '''[https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block]''' {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

Question owner

I was going to try your latest idea but suddenly I was unable to get anything to load, whether Facebook or Verizon or Godaddy or MyLesPaul.com... just that infuriating counterclockwise "Loading" symbol. A restart got me back in the saddle. Maybe now my machine is ready to work with me a bit. (Could be that crappy box that Comcast forced us all to switch to a few months ago, I dunno)

I was going to try your latest idea but suddenly I was unable to get anything to load, whether Facebook or Verizon or Godaddy or MyLesPaul.com... just that infuriating counterclockwise "Loading" symbol. A restart got me back in the saddle. Maybe now my machine is ready to work with me a bit. (Could be that crappy box that Comcast forced us all to switch to a few months ago, I dunno)

Question owner

BTW, with the new profile, the cache fills up faster than ever. Must be emptied several times a day, or whenever I see the dreaded words "Firefox (not responding)"

BTW, with the new profile, the cache fills up faster than ever. Must be emptied several times a day, or whenever I see the dreaded words "Firefox (not responding)"

Question owner

Well, I downloaded yet another version of Flash and took your advice, returning to my old profile and refreshing it. After countless openings and closings and re-entering of passwords, I think the problem is solved. The only issues left (latency, and CPU Usage graphs that looks like skyscrapers, and I still get those damned "ADOBE FLASH IS NOT RESPONDING" messages) are probably not FF-related?

The most in-my-face problem has been solved, it seems... thanks to all of you. The big hurdle left is to try to make Flash behave.

For a week or so I have been running 2 AV programs simultaneously (ESET and Avira), but that did not seem to make anything better or worse, so for now i let them both run, as eset caught stuff that avira did not, but eset will disappear in a week and avira runs forever for free, the only price being stupid popup ads trying to scare me into paying $$$ for a better version.

Well, I downloaded yet another version of Flash and took your advice, returning to my old profile and refreshing it. After countless openings and closings and re-entering of passwords, I think the problem is solved. The only issues left (latency, and CPU Usage graphs that looks like skyscrapers, and I still get those damned "ADOBE FLASH IS NOT RESPONDING" messages) are probably not FF-related? The most in-my-face problem has been solved, it seems... thanks to all of you. The big hurdle left is to try to make Flash behave. For a week or so I have been running 2 AV programs simultaneously (ESET and Avira), but that did not seem to make anything better or worse, so for now i let them both run, as eset caught stuff that avira did not, but eset will disappear in a week and avira runs forever for free, the only price being stupid popup ads trying to scare me into paying $$$ for a better version.

Modified by TIMSPORES

Question owner

Still getting the "warning: unresponsive script. firefox (not responding)" but it doesn't linger as long as it used to.

it's still unnerving. but still, it's good to have ff back.

Still getting the "warning: unresponsive script. firefox (not responding)" but it doesn't linger as long as it used to. it's still unnerving. but still, it's good to have ff back.
FredMcD
  • Top 10 Contributor
4267 solutions 59838 answers

Some think its a bad idea to run more then one anti-virus. If you are going to drop one of them, do it now thru your uninstaller.

Are you still using the Flash Block Add-on? If so, do you still get errors?

Some think its a bad idea to run more then one anti-virus. If you are going to drop one of them, do it now thru your uninstaller. Are you still using the Flash Block Add-on? If so, do you still get errors?