Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

how to block Firefox from playing mp3 and allow me to save the file

  • 18 risposte
  • 12 hanno questo problema
  • 5072 visualizzazioni
  • Ultima risposta di cor-el

more options

I have upgraded to Firefox v28. I want to save a mp3 file for playing later like previous versions of Firefox. When I click the file it starts playing and does not give me the option to save the file. In Options the 'application' settings for file type MP3 is set to 'save file'. The quicktime plugin is disabled. The media.windows-media-foundation.enabled is set to false in about:config How can I restore Firefox behavior to be like the old versions Thanks

Soluzione scelta

That fixed it! Thank you!

Leggere questa risposta nel contesto 👍 1

Tutte le risposte (18)

more options

Can't you save the file via the right-click context menu of the player?

You can also try to set the media.windows-media-foundation.play-stand-alone pref to false.

more options

I set the media.windows-media-foundation.play-stand-alone pref to false but it did not help. I also set media.windows-media-foundation.use-dxva to false but it did not help. The right click in the player does allow me to save the file but it is an extra step. I still prefer the old method. Thanks

more options

I suffer from the same problem. It was so easy to save the file with one click (default setting). Now, regardless of Options/Applications and about:config settings Firefox always plays the MP3.

I am not sure which update caused that.

Yes, I can save with right click, but it takes two more clicks. Saving more than 2 files becomes inconvenient.

System: Windows 7 Ult, 64b

more options

Firefox Settings > Applications. Look for all the file types and set them to Always Ask, or Save File.

more options

Tried that. Firefox does not honor the "save file" option. It always plays the file

more options

Go to the Mozilla Add-ons Web Page (There’s a lot of good stuff here) and check out Flash block Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way

This also works on MP3.

more options

Try to set the Boolean pref media.directshow.enabled to false as well on the about:config page.

You can also set the browser.altClickSave pref to true and hold down the Alt key when you left-click an MP3 link.

more options

Soluzione scelta

That fixed it! Thank you!

more options

Yes, that worked. Now I must depress the ALT key, but at least it works.

On a side note - why it does not work anymore as it used to?

more options

Set media.directshow.enabled to false on the about:config page and it works the way it used to

more options

Nope, it does not work for whatever reason. See this site: http://www.rmf.fm/rss/podcast/olo.xml

I do not know what is wrong, maybe some other settings... but it works only with ALT key.

So take a look on those MP3's and tell me if you can save them with one click.

Modificato da PLP il

more options

And yes, it is still unresolved in my case.

more options

Yes, I can save them with one click. Look at the early entries to this thread. Do you have all those config settings as false?

more options

Yes, both are FALSE.

It used to work until some day. To add to confusion. It works OK on my other machine. I guess I will have to compare all the settings.

more options

Those mp3 files from the RSS feed are send as audio/mpeg by the server and thus played by the HTML5 media player is support for mp3 is enabled.
You can always use "Save Link As" in the right-click context menu to save such a file to disk.

more options

so should it work with settings as outlined above by left click (auto save)? or I must use right save as or ALT combination?

more options

You can choose for yourself what works best for you.

If you still wish to have the HTML5 media player enabled then you can use the Alt key method or the right-click context menu. The right-click context menu should also work with the HTML5 media player as long as the player is visible.