Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

None of the "sha256" hashes in the integrity attribute match the content of the subresource

  • 2 risposte
  • 1 ha questo problema
  • 3140 visualizzazioni
  • Ultima risposta di igorw

more options

We created a web site that uses resources from cdnjs. This site has been live for a couple of months but we have sporadic issues with resources from this CDN and FireFox.

  • The error in the console for each script/style CDN resource is: None of the "sha256" hashes in the integrity attribute match the content of the subresource.
  • The error message in the network tab for each resource is: The connection used to fetch this resource was not secure

Resources that I have had issues with include these elements (as they appear in our web page):

Steps to reproduce

You can reproduce the problem with one of the above URLs and place it directly in the URL of the FireFox browser. The resource should load in the browser window but after pressing CTRL+F5 at least one time (could be up to 5 times) an error will appear. I can duplicate this from multiple PCs although we are located in the Netherlands so maybe a timing issue or something? This does not happen with any other resources from other CDNs that we are using like (we use integrity checks with these as well):

My environment:

  • Windows 10 Pro 64bit patched to latest
  • FireFox 60.0.1 (64-bit)

My question

Is this an issue that is specific to cdnjs and they must resolve this or is this an issue with FireFox or is this an issue with how we are requesting the resource? Is there anything else that we can do to get the ball rolling on fixing this (depending on the actual source of the problem)?

As a side note we also test our software on Google Chrome, MS Internet Explorer, MS Internet Explorer 11, MS Edge, and Opera and we have

Thank you in advance!

-Igor

Modificato da igorw il

Soluzione scelta

@Pkshadow - Thank you for your suggestion. I have created a post on Stack Overflow. As per your recommendation I will mark this question as closed.

Leggere questa risposta nel contesto 👍 0

All Replies (2)

more options

Hi, this is some what beyond what Firefox Support Volunteers do.

If you have a bug, file a bug report.

Bug Writing Guidelines :

Also info :

and

Since mozilla.org and some other URL's download a Stub Installer that maybe the issue you are having. Try full version installers :

Please let us know if this solved your issue or if need further assistance.

more options

Soluzione scelta

@Pkshadow - Thank you for your suggestion. I have created a post on Stack Overflow. As per your recommendation I will mark this question as closed.