Improvvisa apertura di molte schede o finestre in Firefox

Utilizzando Firefox è possibile che quando si fa clic su un collegamento ipertestuale (link) vengano ripetutamente aperte nuove schede o finestre vuote, obbligando alla chiusura del programma. Le stesse schede prive di titolo o finestre vuote potrebbero poi riaprirsi al successivo avvio di Firefox se viene scelto di ripristinare la precedente sessione di navigazione.

Di solito questo problema si presenta quando si imposta Firefox come il programma predefinito da utilizzare per una particolare azione, come ad esempio aprire certi tipi di file o avviare un'applicazione per la posta elettronica.

Nota: La funzione di ripristino di Firefox può essere risolutiva in molte occasioni in quanto consente di riportare Firefox ai suoi valori predefiniti effettuando contemporaneamente il salvataggio delle informazioni personali. È da prendere sicuramente in considerazione prima di avventurarsi in lunghe procedure di risoluzione dei problemi.

Avviare una nuova sessione di Firefox

Nel caso in cui si verificasse ripetutamente l'apertura di molteplici schede o finestre, si potrebbe essere costretti a chiudere Firefox. In Firefox è disponibile una caratteristica, il Ripristino della sessione, che permette di ripristinare dopo un crash o una chiusura inaspettata le finestre e le schede aperte nella precedente sessione.

Al riavvio di Firefox potrebbero iniziare ad aprirsi le stesse molteplici schede o finestre rendendo così necessaria una nuova chiusura di Firefox. Se al riavvio di Firefox viene visualizzata una pagina di Ripristino della sessione (ad esempio "Oops, questo è imbarazzante"), fare clic sul pulsante Avvia una nuova sessione.

Una volta avviata una nuova sessione di Firefox, per risolvere il problema, seguire le istruzioni riportate di seguito.


Modificare l'azione predefinita per lo specifico tipo di contenuto

Dovrebbe essere possibile risolvere l'anomalia individuando il tipo di contenuto configurato per avviare Firefox e modificando l'azione associata. Seguire questa procedura:

  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e selezionare Opzioni.Dal menu in alto nella finestra di Firefox fare clic sul menu Strumenti e selezionare Opzioni.Dalla barra dei menu fare clic sul menu Firefox e selezionare Preferenze....Dal menu in alto nella finestra di Firefox fare clic sul menu Modifica e selezionare Preferenze.

    Fare clic sul pulsante dei menu New Fx Menu e selezionare OpzioniPreferenze.

  2. Selezionare il pannello Applicazioni.
  3. Se si conosce quale elemento nella colonna Tipo di contenuto sta causando il problema, selezionarlo. Altrimenti, nel campo di ricerca, digitare Usa Firefox. In questo modo nell'elenco saranno visualizzati solamente gli elementi per i quali è selezionata l'opzione "Usa Firefox".

    0124711d66acaaad1402def578674d46-1266165285-270-1.png
  4. Per ciascuno di questi tipi di contenuto, selezionare una nuova azione dal menu nella colonna Azione. Se non si è sicuri dell'azione da selezionare, scegliere l'opzione Chiedi ogni volta.
  5. Fare clic su OK per chiudere la finestra delle opzioniFare clic su Chiudi per chiudere la finestra delle preferenzeChiudere la finestra delle preferenze.

Per informazioni generali sui tipi di contenuto, leggere Gestione dei tipi di file.


Ripristinare le azioni predefinite per tutti i tipi di contenuto

Se la procedura descritta in precedenza non è risolutiva, o se non si riesce ad individuare nell'elenco delle applicazioni l'elemento che provoca il problema, è opportuno reimpostare le azioni per tutti i tipi di contenuto cancellando manualmente il file che contiene queste impostazioni.

In questo modo verranno eliminare tutte le azioni personalizzate relative ai contenuti, non soltanto quella che sta causando il problema. Una volta effettuata questa operazione, le personalizzazioni dovranno essere effettuate nuovamente.
  1. Aprire la cartella del profilo:

    Dal menu in alto nella finestra di Firefox, fare clic sul pulsante Firefox, spostarsi sul menu AiutoSulla barra dei menu, fare clic su AiutoDal menu in alto nella finestra di Firefox, fare clic su Aiuto e selezionare Risoluzione dei problemi. Verrà aperta la pagina di Informazioni per la risoluzione dei problemi in una nuova scheda.Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di aiuto Help-29 , quindi selezionare Risoluzione dei problemi. Verrà aperta la pagina di Informazioni per la risoluzione dei problemi in una nuova scheda.

  2. Nella sezione Informazioni di base, fare clic sul pulsante Mostra cartellaMostra nel FinderApri percorso. Verrà aperta una finestra con i filela cartella del profilo.
  3. Nota: nel caso in cui non sia possibile aprire o utilizzare Firefox, seguire le istruzioni contenute in Individuare il profilo senza avviare Firefox.

  4. Chiudere Firefox.

    Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox e successivamente su Esci.Nella parte superiore della finestra di Firefox, fare clic sul menu File e successivamente su Esci.Sulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefox.Nella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci.

    Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di chiusura Close 29

  5. Cancellare il file di nome mimeTypes.rdf.
  6. Riavviare Firefox.

Verificare la presenza di un programma malevolo

Se il problema non viene ancora risolto o se si aprono in Firefox molteplici schede o finestre dai contenuti indesiderati, è possibile che il proprio sistema possa essere stato infettato da un malware. Per maggiori informazioni, leggere l'articolo Come capire se un malware impedisce il corretto funzionamento di Firefox.



Condividi questo articolo: http://mzl.la/NGHy6x

È stato utile questo articolo? Attendere...

Utenti che hanno contribuito a scrivere questo articolo: underpass, michro. Tutti possono contribuire.