Effettuare il backup dei dati personali

In Firefox tutti i dati utente (come ad esempio i segnalibri, le password e le estensioni) vengono salvati in una speciale cartella del computer utilizzato - diversa da quella in cui è installato il programma - denominata cartella del profilo. In questo articolo viene spiegato come effettuare una copia di sicurezza (backup) del profilo, come ripristinarla e come spostare il profilo in una nuova posizione o su un altro computer.

Individuare la cartella del profilo

La posizione predefinita della cartella del profilo di Firefox è %APPDATA%\Mozilla\Firefox\Profiles\xxxxxxxx.default\.

  • %APPDATA% è una scorciatoia per la cartella C:\Users\<nome utente>\AppData\Roaming\C:\Documents and Settings\<nome utente>\Dati applicazioni\, che dipende dal nome utente utilizzato per l'accesso a Windows.

Ogni profilo viene salvato sul disco fisso una speciale cartella del profilo. Per impostazione predefinita il profilo di Firefox è ~/Libreria/Application Support/Firefox/Profiles/xxxxxxxx.default/.

Ogni profilo viene salvato sul disco fisso in una speciale cartella del profilo. L'impostazione predefinita per il profilo di Firefox è ~/.mozilla/firefox/xxxxxxxx.default/.

  • xxxxxxxx è una stringa casuale di 8 caratteri.

È possibile individuare la cartella del profilo seguendo queste istruzioni:

  1. Fare clic sul pulsante Start, e digitare %APPDATA%\Mozilla\Firefox\Profiles\ nella casella di ricerca posta accanto alla base del menu Start, senza premere Invio.
  2. Un elenco di profili apparirà in alto a sinistra nel menu Start. È possibile fare clic su uno dei profili (ad esempio xxxxxxxx.default) per aprirlo con Esplora risorse.
41c16b61bcc518ebcbdc4339347e5fdc-1258914329-163-1.png
  1. Fare clic sul pulsante Start, e selezionare Esegui....

    41c16b61bcc518ebcbdc4339347e5fdc-1257532338-612-2.png
  2. Digitare %APPDATA%\Mozilla\Firefox\Profiles\ quindi fare clic su OK.

    41c16b61bcc518ebcbdc4339347e5fdc-1257532338-612-3.png

    Verrà aperta in Esplora risorse la cartella Profiles, che contiene a sua volta le cartelle di ciascun profilo.
  1. Aprire gli Accessi e selezionare Cerca.
  2. Cercare Esegui in Applicazioni.
  3. Selezionare Esegui nei risultati della ricerca per aprire l'applicazione Esegui nel Desktop.
  4. Nell'applicazione Esegui, digitare %APPDATA%\Mozilla\Firefox\Profiles\ e premere Invio. Verrà aperta in Esplora risorse la cartella Profiles, che contiene a sua volta le cartelle di ciascun profilo.
  1. Fare clic sull'icona Finder nel dock.
  2. Sulla barra dei menu, fare clic sul menu Vai e selezionare Vai alla cartella....
  3. Nella finestra Vai alla cartella, incollare il testo seguente: ~/Library/Application Support/Firefox/Profiles e fare clic sul pulsante Vai.
  4. Verrà aperta una finestra che contiene le cartelle dei profili.
  5. Fare doppio clic sulla cartella che riporta nella parte finale del nome il termine “default” per aprirla.
  1. (Ubuntu) Selezionare la propria Home. Comparirà la finestra di Esplorazione file.
  2. Fare clic sul menu Visualizza e selezionare Mostra file nascosti se non è già selezionato.
  3. Fare doppio clic sulla cartella chiamata .mozilla.
  4. Fare doppio clic sulla cartella firefox. La cartella del profilo è all'interno di questa cartella.

Effettuare un backup del profilo

Per effettuare il backup del profilo, è necessario per prima cosa chiudere completamente Firefox e successivamente copiare la cartella in un'altra destinazione:

  1. Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox e successivamente su Esci.Nella parte superiore della finestra di Firefox, fare clic sul menu File e successivamente su Esci.Sulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefox.Nella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci.

    Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di chiusura Close 29

  2. Individuare la cartella del profilo, come spiegato in precedenza.
  3. Salire di un livello nella visualizzazione delle cartelle del profilo, ad esempio %APPDATA%\Mozilla\Firefox\Profiles\~/Libreria/Application Support/Firefox/Profiles/~/.mozilla/firefox/
  4. Con il clic destroTenendo premuto il tasto Ctrl facendo clic sulla cartella del profilo (ad esempio xxxxxxxx.default) selezionare Copia.
  5. Con il clic destroTenendo premuto il tasto Ctrl facendo clic sulla cartella in cui posizionare il backup (ad esempio una pen-drive USB o un CD registrabile vuoto) selezionare Incolla Elemento.

Ripristinare un backup del profilo

  1. Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox e successivamente su Esci.Nella parte superiore della finestra di Firefox, fare clic sul menu File e successivamente su Esci.Sulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefox.Nella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci.

    Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di chiusura Close 29

  2. Se la cartella del profilo esistente e quella del backup del profilo hanno lo stesso nome, è sufficiente sostituire quella esistente con il backup e riavviare Firefox.
    Importante: perché questa procedura funzioni, i nomi delle cartelle devono essere esattamente identici, inclusi gli 8 caratteri casuali. Se i nomi sono differenti o se si vuole ripristinare il backup in una posizione diversa dall'originale, leggere oltre.

Ripristinare in una posizione diversa

Se i nomi delle cartelle sono diversi o se si ha intenzione di spostare o ripristinare un profilo in una posizione diversa, ecco i passi da seguire:

  1. Chiudere completamente Firefox come spiegato in precedenza.
  2. Utilizzare il gestore dei profili di Firefox per creare un nuovo profilo nella posizione desiderata e successivamente chiudere il gestore dei profili.
    Nota: se Firefox è stato appena installato su un nuovo computer è possibile ignorare questo punto ed utilizzare il profilo predefinito creato automaticamente invece di crearne uno nuovo.
  3. Individuare la cartella principale del profilo sul disco fisso o sul dispositivo di backup (ad esempio la pen-drive USB).
  4. Aprire la copia salvata in precedenza del profilo (cioè la cartella xxxxxxxx.default).
  5. Utilizzando il menu contestuale, copiare tutto il contenuto della cartella del profilo salvata - cioè il file mimeTypes.rdf, il file prefs.js, la cartella bookmarkbackups, ecc. ecc.
  6. Individuare a aprire la nuova cartella del profilo così come spiegato precedentemente. Chiudere Firefox (se è ancora in esecuzione).
  7. Utilizzando il menu contestuale, incollare il contenuto della cartella del profilo salvata all'interno della nuova cartella sovrascrivendo i file con lo stesso nome.
  8. Avviare Firefox.



Condividi questo articolo: http://mzl.la/LHJo6V

È stato utile questo articolo? Attendere...

Utenti che hanno contribuito a scrivere questo articolo: underpass, michro. Tutti possono contribuire.